aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandeep Sheriker M <sandeep.sheriker@microchip.com>2019-08-14 21:02:16 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-17 23:08:59 +0200
commit05a81abb5ff58501d589b2c949b607e515b52f92 (patch)
tree399b2b0e8315cdf2fdd1f2e58b5e7e7b4050179b
parent575950e37698b5d59f7a30a44f92327844c58b99 (diff)
downloadupstream-05a81abb5ff58501d589b2c949b607e515b52f92.tar.gz
upstream-05a81abb5ff58501d589b2c949b607e515b52f92.tar.bz2
upstream-05a81abb5ff58501d589b2c949b607e515b52f92.zip
at91: remove Build/at91-sdcard command
remove at91-sdcard build command from Makefile as this is moved to respective subtarget Makefile. Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
-rw-r--r--target/linux/at91/image/Makefile35
1 files changed, 0 insertions, 35 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 3a906a6ca8..3b01d42131 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -40,41 +40,6 @@ define Device/dtb
KERNEL := kernel-bin | lzma | uImage lzma
endef
-define Build/at91-sdcard
- $(if $(findstring ext4,$@), \
- rm -f $@.boot
- mkfs.fat -C $@.boot $(FAT32_BLOCKS)
-
- mcopy -i $@.boot $(KDIR)/zImage ::zImage
-
- $(foreach dts,$(DEVICE_DTS), \
- mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb \
- ::$(dts).dtb)
-
- mcopy -i $@.boot \
- $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
- ::u-boot.bin
-
- $(if $(findstring at91-sama5d27_som1_ek,$@), \
- mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd1_uboot/at91bootstrap.bin \
- ::BOOT.bin,
- mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot/at91bootstrap.bin \
- ::BOOT.bin)
-
- ./gen_at91_sdcard_img.sh \
- $@.img \
- $@.boot \
- $(KDIR)/root.ext4 \
- $(AT91_SD_BOOT_PARTSIZE) \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE)
-
- gzip -nc9 $@.img > $@
-
- rm -f $@.img $@.boot )
-endef
-
define Device/evaluation-sdimage
IMAGES += sdcard.img.gz
IMAGE/sdcard.img.gz := at91-sdcard