aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-11-03 14:58:32 +0000
committerMichael Büsch <mb@bu3sch.de>2010-11-03 14:58:32 +0000
commit050902efd70bf8d4c88c8ce4124bd8cbe15548c7 (patch)
tree06ce65551e4782323464ffab8d8802f561fa0942
parentf75ac90b695da2226a25c47d30156983df87ec7b (diff)
downloadupstream-050902efd70bf8d4c88c8ce4124bd8cbe15548c7.tar.gz
upstream-050902efd70bf8d4c88c8ce4124bd8cbe15548c7.tar.bz2
upstream-050902efd70bf8d4c88c8ce4124bd8cbe15548c7.zip
deptest: Install of host tools has to be forced for every test, because the host staging dir is cleaned prior a test.
SVN-Revision: 23825
-rw-r--r--include/host-build.mk4
-rwxr-xr-xscripts/deptest.sh1
2 files changed, 3 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 1b7f354066..6f742d28a1 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -153,12 +153,12 @@ ifndef DUMP
$(call Host/Compile)
touch $$@
- $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
+ $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
$(call Host/Install)
mkdir -p $$(shell dirname $$@)
touch $$@
else
- $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+ $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED) $(if $(FORCE_HOST_INSTALL),FORCE)
$(call Host/Compile)
$(call Host/Install)
touch $$@
diff --git a/scripts/deptest.sh b/scripts/deptest.sh
index 730ca5bd35..a0c3017c7d 100755
--- a/scripts/deptest.sh
+++ b/scripts/deptest.sh
@@ -74,6 +74,7 @@ test_package() # $1=pkgname
BUILD_DIR_HOST="$BUILD_DIR_HOST" \
STAGING_DIR="$STAGING_DIR" \
STAGING_DIR_HOST="$STAGING_DIR_HOST" \
+ FORCE_HOST_INSTALL=1 \
V=99 >"$LOG_DIR/$(basename $pkg).log" 2>&1
if [ $? -eq 0 ]; then
touch "$STAMP_SUCCESS"