aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Kudielka <klaus.kudielka@gmail.com>2019-12-27 19:15:31 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-13 13:56:47 +0200
commit04d3b517dc3301e0148a2ce811ffc136568b04bd (patch)
treea6d50e66ce8bd9aa0a8d2200a3d6a4e7cf196716
parent2188ef954ee32ec0b24674f07634f39ecf63c38e (diff)
downloadupstream-04d3b517dc3301e0148a2ce811ffc136568b04bd.tar.gz
upstream-04d3b517dc3301e0148a2ce811ffc136568b04bd.tar.bz2
upstream-04d3b517dc3301e0148a2ce811ffc136568b04bd.zip
uboot-envtools: mvebu: update uci defaults for Turris Omnia
On the Turris Omnia 2019, u-boot environment is located at 0xF0000, instead of 0xC0000. The switch happened with u-boot-omnia package version 2019-04-2 (May 10, 2019). Check the installed u-boot release, and set the default accordingly. Signed-off-by: Klaus Kudielka <klaus.kudielka@gmail.com> [bump PKG_RELEASE, use lower case for hex offset] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--package/boot/uboot-envtools/Makefile2
-rw-r--r--package/boot/uboot-envtools/files/mvebu6
2 files changed, 6 insertions, 2 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 7d464f8d08..473704053c 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-envtools
PKG_DISTNAME:=u-boot
PKG_VERSION:=2020.04
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
diff --git a/package/boot/uboot-envtools/files/mvebu b/package/boot/uboot-envtools/files/mvebu
index 8ed1f87ead..1d3b79b962 100644
--- a/package/boot/uboot-envtools/files/mvebu
+++ b/package/boot/uboot-envtools/files/mvebu
@@ -15,7 +15,11 @@ board=$(board_name)
case "$board" in
cznic,turris-omnia)
- ubootenv_add_uci_config "/dev/mtd0" "0xC0000" "0x10000" "0x40000"
+ if grep -q 'U-Boot 2015.10-rc2' /dev/mtd0; then
+ ubootenv_add_uci_config "/dev/mtd0" "0xc0000" "0x10000" "0x40000"
+ else
+ ubootenv_add_uci_config "/dev/mtd0" "0xf0000" "0x10000" "0x10000"
+ fi
;;
glinet,gl-mv1000)
ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x8000" "0x8000" "1"