aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDobroslaw Kijowski <dobo90@gmail.com>2020-11-16 20:21:46 +0100
committerDavid Bauer <mail@david-bauer.net>2020-11-17 17:05:20 +0100
commit03cdeb5f97f82d4be34e3545efa47c0b9aa0fc05 (patch)
tree59b55ce200d533a071fcf2ee39821b16658f1453
parent0ce5f15f9c51926bc56aa8f9d8d848f803f9f251 (diff)
downloadupstream-03cdeb5f97f82d4be34e3545efa47c0b9aa0fc05.tar.gz
upstream-03cdeb5f97f82d4be34e3545efa47c0b9aa0fc05.tar.bz2
upstream-03cdeb5f97f82d4be34e3545efa47c0b9aa0fc05.zip
hostapd: fix per-BSS airtime configuration
airtime_mode is always parsed as an empty string since it hasn't been added into hostapd_common_add_device_config function. Fixes: e289f183 ("hostapd: add support for per-BSS airtime configuration") Signed-off-by: Dobroslaw Kijowski <dobo90@gmail.com>
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 8c884386f2..9a8a74ced9 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=14
+PKG_RELEASE:=15
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index 3dbb983170..8a07e4d52b 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -102,6 +102,8 @@ hostapd_common_add_device_config() {
config_add_string acs_chan_bias
config_add_array hostapd_options
+ config_add_int airtime_mode
+
hostapd_add_log_config
}