aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2021-05-08 17:34:30 -0400
committerPetr Štetiar <ynezz@true.cz>2021-06-11 07:20:31 +0200
commit02b7b773329a2956fec6f5a08d97c3c69aa18964 (patch)
tree6be41734ead4c37f9764dfe432658d19e4379676
parent349a4f453146d2022b7c5856d011d0807b95ae44 (diff)
downloadupstream-02b7b773329a2956fec6f5a08d97c3c69aa18964.tar.gz
upstream-02b7b773329a2956fec6f5a08d97c3c69aa18964.tar.bz2
upstream-02b7b773329a2956fec6f5a08d97c3c69aa18964.zip
ath79: set lzma-loader variables to null by default
This fixes a small regression where the lzma-loader variable values are being shared between boards that require different configurations. If not set to "" globally, a device without these settings will just take the last values another device has set before in the queue. Fixes: 1b8bd17c2d07 ("ath79: lzma-loader: allow setting custom kernel magic") Signed-off-by: Michael Pratt <mcpratt@pm.me> [add detailed explanation to the commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit bf8c16dfa2cddd529f889510ca5fa5160606c325)
-rw-r--r--target/linux/ath79/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index d8b8800d91..3c126f479e 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -70,6 +70,10 @@ define Device/Default
BLOCKSIZE := 64k
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
+ LOADER_KERNEL_MAGIC :=
+ LOADER_FLASH_MAX :=
+ LOADER_FLASH_OFFS :=
+ LOADER_TYPE :=
COMPILE :=
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \