aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-10-27 12:33:00 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-10-27 12:33:00 +0000
commit01c84498658e61f08d2016ee8a4a6c1ad3d25edd (patch)
tree42497da744c8f8445121a302b3138797364eb45d
parent1a4f117398d1a0cea846f2ddf44140a95a3bd0fe (diff)
downloadupstream-01c84498658e61f08d2016ee8a4a6c1ad3d25edd.tar.gz
upstream-01c84498658e61f08d2016ee8a4a6c1ad3d25edd.tar.bz2
upstream-01c84498658e61f08d2016ee8a4a6c1ad3d25edd.zip
package/kernel: arc4 needs blkcipher support on 3.6
[ 78.530000] arc4: Unknown symbol blkcipher_walk_done (err 0) [ 78.530000] arc4: Unknown symbol blkcipher_walk_virt (err 0) [ 78.540000] arc4: Unknown symbol crypto_blkcipher_type (err 0) Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 33965
-rw-r--r--package/kernel/modules/crypto.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 43a7cc3431..dc21c1d53a 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -192,7 +192,7 @@ define KernelPackage/crypto-arc4
KCONFIG:=CONFIG_CRYPTO_ARC4
FILES:=$(LINUX_DIR)/crypto/arc4.ko
AUTOLOAD:=$(call AutoLoad,09,arc4)
- $(call AddDepends/crypto)
+ $(call AddDepends/crypto,+!LINUX_3_3:kmod-crypto-manager)
endef
$(eval $(call KernelPackage,crypto-arc4))