aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVitaly Chekryzhev <13hakta@gmail.com>2017-01-05 12:06:26 +0500
committerStijn Tintel <stijn@linux-ipv6.be>2017-03-18 12:08:04 +0100
commit01337ba472d0661af1e3b397be3c40573e46ea69 (patch)
tree4b2b68d872bee270e01707c62470929c28dd31a7
parent3ceb0fa7c587e10748d70c9ec860d9b0ab16549e (diff)
downloadupstream-01337ba472d0661af1e3b397be3c40573e46ea69.tar.gz
upstream-01337ba472d0661af1e3b397be3c40573e46ea69.tar.bz2
upstream-01337ba472d0661af1e3b397be3c40573e46ea69.zip
build: add devel option to store build config in firmware
Store config.seed in firmware /etc/build.config Signed-off-by: Vitaly Chekryzhev <13hakta@gmail.com>
-rw-r--r--config/Config-build.in6
-rw-r--r--package/base-files/Makefile4
2 files changed, 10 insertions, 0 deletions
diff --git a/config/Config-build.in b/config/Config-build.in
index e0889fcccf..d5e183926d 100644
--- a/config/Config-build.in
+++ b/config/Config-build.in
@@ -67,6 +67,12 @@ menu "Global build settings"
This removes all ipkg/opkg status data files from the target directory
before building the root filesystem.
+ config INCLUDE_CONFIG
+ bool "Include build configuration in firmware" if DEVEL
+ default n
+ help
+ If enabled, config.seed will be stored in /etc/build.config of firmware.
+
config COLLECT_KERNEL_DEBUG
bool
prompt "Collect kernel debug information"
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 78c3dc9390..512fa66ca7 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -168,6 +168,10 @@ define Package/base-files/install
echo "$$$${conffile##$(1)}" >> $(1)/CONTROL/conffiles; \
fi \
done
+
+ $(if $(CONFIG_INCLUDE_CONFIG), \
+ echo -e "# Build configuration for board $(BOARD)/$(SUBTARGET)/$(PROFILE)\n" >$(1)/etc/build.config; \
+ cat $(BIN_DIR)/config.seed >>$(1)/etc/build.config)
endef
ifneq ($(DUMP),1)