aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2019-01-25 22:04:40 +0100
committerMathias Kresin <dev@kresin.me>2019-01-26 15:23:37 +0100
commit0013c9402513e5ef65eeaf0a2b3e84af0db19740 (patch)
treecfa99c14a722622d6cba761ba74e8d7b8c25e572
parentb9c6862d9db25484c6103c21f3cb363a7db5b3c7 (diff)
downloadupstream-0013c9402513e5ef65eeaf0a2b3e84af0db19740.tar.gz
upstream-0013c9402513e5ef65eeaf0a2b3e84af0db19740.tar.bz2
upstream-0013c9402513e5ef65eeaf0a2b3e84af0db19740.zip
gemini: use dts compatible based image filenames
Use an output image filename based on the compatible string from the dts files. This way it is way easier to get for which board an image is intended. Signed-off-by: Mathias Kresin <dev@kresin.me>
-rw-r--r--target/linux/gemini/image/ImageInfo-itian_sq201 (renamed from target/linux/gemini/image/ImageInfo-sq201)0
-rw-r--r--target/linux/gemini/image/ImageInfo-raidsonic_ib-4220-b (renamed from target/linux/gemini/image/ImageInfo-nas4220b)0
-rw-r--r--target/linux/gemini/image/Makefile36
3 files changed, 21 insertions, 15 deletions
diff --git a/target/linux/gemini/image/ImageInfo-sq201 b/target/linux/gemini/image/ImageInfo-itian_sq201
index 86040ab470..86040ab470 100644
--- a/target/linux/gemini/image/ImageInfo-sq201
+++ b/target/linux/gemini/image/ImageInfo-itian_sq201
diff --git a/target/linux/gemini/image/ImageInfo-nas4220b b/target/linux/gemini/image/ImageInfo-raidsonic_ib-4220-b
index 68fca5bb93..68fca5bb93 100644
--- a/target/linux/gemini/image/ImageInfo-nas4220b
+++ b/target/linux/gemini/image/ImageInfo-raidsonic_ib-4220-b
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index ca0cb001e4..3f4dc62677 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -80,7 +80,6 @@ endef
# All DTB files are prefixed with "gemini-"
define Device/Default
PROFILES := Default
- DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL_NAME := zImage
KERNEL := kernel-bin | append-dtb
@@ -96,23 +95,25 @@ GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
kmod-nls-utf8 kmod-usb-storage-extras \
samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
-define Device/dlink-dir-685
+define Device/dlink_dir-685
DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
+ DEVICE_DTS := gemini-dlink-dir-685
DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
kmod-switch-rtl8366rb swconfig \
rt2800-pci
IMAGES := factory.bin
IMAGE/factory.bin := dir685-images
endef
-TARGET_DEVICES += dlink-dir-685
+TARGET_DEVICES += dlink_dir-685
-define Device/dlink-dns-313
+define Device/dlink_dns-313
DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
+ DEVICE_DTS := gemini-dlink-dns-313
DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
IMAGES := factory.bin
IMAGE/factory.bin := dns313-images
endef
-TARGET_DEVICES += dlink-dns-313
+TARGET_DEVICES += dlink_dns-313
define Device/nas4220b-sq201
IMAGES := factory.bin
@@ -120,35 +121,40 @@ define Device/nas4220b-sq201
DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
endef
-define Device/nas4220b
+define Device/raidsonic_ib-4220-b
$(Device/nas4220b-sq201)
DEVICE_TITLE := Raidsonic NAS IB-4220-B
+ DEVICE_DTS := gemini-nas4220b
endef
-TARGET_DEVICES += nas4220b
+TARGET_DEVICES += raidsonic_ib-4220-b
-define Device/rut1xx
+define Device/teltonika_rut1xx
DEVICE_TITLE := Teltonika RUT1xx
+ DEVICE_DTS := gemini-rut1xx
DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
endef
-TARGET_DEVICES += rut1xx
+TARGET_DEVICES += teltonika_rut1xx
-define Device/sq201
+define Device/itian_sq201
$(Device/nas4220b-sq201)
DEVICE_TITLE := ITian Square One SQ201
+ DEVICE_DTS := gemini-sq201
DEVICE_PACKAGES += rt61-pci usb2-pci
endef
-TARGET_DEVICES += sq201
+TARGET_DEVICES += itian_sq201
-define Device/wbd111
+define Device/wiliboard_wbd111
DEVICE_TITLE := Wiliboard WBD-111
+ DEVICE_DTS := gemini-wbd111
KERNEL := kernel-bin | append-dtb | wbd-nops
endef
-TARGET_DEVICES += wbd111
+TARGET_DEVICES += wiliboard_wbd111
-define Device/wbd222
+define Device/wiliboard_wbd222
DEVICE_TITLE := Wiliboard WBD-222
+ DEVICE_DTS := gemini-wbd222
KERNEL := kernel-bin | append-dtb | wbd-nops
endef
-TARGET_DEVICES += wbd222
+TARGET_DEVICES += wiliboard_wbd222
$(eval $(call BuildImage))