aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/patches-4.1/162-clk-sunxi-codec-clock.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/sunxi/patches-4.1/162-clk-sunxi-codec-clock.patch')
-rw-r--r--target/linux/sunxi/patches-4.1/162-clk-sunxi-codec-clock.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/target/linux/sunxi/patches-4.1/162-clk-sunxi-codec-clock.patch b/target/linux/sunxi/patches-4.1/162-clk-sunxi-codec-clock.patch
new file mode 100644
index 0000000..c19d7a6
--- /dev/null
+++ b/target/linux/sunxi/patches-4.1/162-clk-sunxi-codec-clock.patch
@@ -0,0 +1,73 @@
+From 9b95732096c11d84bd0082aed0d575d8c09e3ab6 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Emilio=20L=C3=B3pez?= <emilio@elopez.com.ar>
+Date: Fri, 18 Jul 2014 15:49:37 -0300
+Subject: [PATCH] clk: sunxi: codec clock support
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The codec clock on sun4i, sun5i and sun7i is a simple gate with PLL2 as
+parent.
+
+Signed-off-by: Emilio López <emilio@elopez.com.ar>
+Signed-off-by: Hans de Goede <hdegoede@redhat.com>
+---
+ drivers/clk/sunxi/Makefile | 1 +
+ drivers/clk/sunxi/clk-a10-codec.c | 41 +++++++++++++++++++++++++++++++++++++++
+ 2 files changed, 42 insertions(+)
+ create mode 100644 drivers/clk/sunxi/clk-a10-codec.c
+
+--- a/drivers/clk/sunxi/Makefile
++++ b/drivers/clk/sunxi/Makefile
+@@ -3,6 +3,7 @@
+ #
+
+ obj-y += clk-sunxi.o clk-factors.o
++obj-y += clk-a10-codec.o
+ obj-y += clk-a10-hosc.o
+ obj-y += clk-a10-pll2.o
+ obj-y += clk-a20-gmac.o
+--- /dev/null
++++ b/drivers/clk/sunxi/clk-a10-codec.c
+@@ -0,0 +1,41 @@
++/*
++ * Copyright 2013 Emilio López
++ *
++ * Emilio López <emilio@elopez.com.ar>
++ *
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License as published by
++ * the Free Software Foundation; either version 2 of the License, or
++ * (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * GNU General Public License for more details.
++ */
++
++#include <linux/clk-provider.h>
++#include <linux/clkdev.h>
++#include <linux/of.h>
++#include <linux/of_address.h>
++
++#define SUN4I_CODEC_GATE 31
++
++static void __init sun4i_codec_clk_setup(struct device_node *node)
++{
++ struct clk *clk;
++ const char *clk_name = node->name, *parent_name;
++ void __iomem *reg;
++
++ of_property_read_string(node, "clock-output-names", &clk_name);
++ parent_name = of_clk_get_parent_name(node, 0);
++ reg = of_iomap(node, 0);
++
++ clk = clk_register_gate(NULL, clk_name, parent_name,
++ CLK_SET_RATE_PARENT, reg,
++ SUN4I_CODEC_GATE, 0, NULL);
++
++ if (!IS_ERR(clk))
++ of_clk_add_provider(node, of_clk_src_simple_get, clk);
++}
++CLK_OF_DECLARE(sun4i_codec, "allwinner,sun4i-a10-codec-clk", sun4i_codec_clk_setup);