aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/mt7621/profiles')
-rw-r--r--target/linux/ramips/mt7621/profiles/00-default.mk18
-rw-r--r--target/linux/ramips/mt7621/profiles/firefly.mk18
-rw-r--r--target/linux/ramips/mt7621/profiles/linksys.mk15
-rw-r--r--target/linux/ramips/mt7621/profiles/misc.mk20
-rw-r--r--target/linux/ramips/mt7621/profiles/storylink.mk18
-rw-r--r--target/linux/ramips/mt7621/profiles/zbt.mk20
6 files changed, 109 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/00-default.mk b/target/linux/ramips/mt7621/profiles/00-default.mk
new file mode 100644
index 0000000..fb04ba7
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/00-default.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ramips/mt7621/profiles/firefly.mk b/target/linux/ramips/mt7621/profiles/firefly.mk
new file mode 100644
index 0000000..bc50ab4
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/firefly.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FIREWRT
+ NAME:=Firefly FireWRT
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/FIREWRT/Description
+ Package set compatible with the Firefly FireWRT board.
+endef
+$(eval $(call Profile,FIREWRT))
diff --git a/target/linux/ramips/mt7621/profiles/linksys.mk b/target/linux/ramips/mt7621/profiles/linksys.mk
new file mode 100644
index 0000000..fb447c9
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/linksys.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RE6500
+ NAME:=Linksys RE6500
+endef
+
+define Profile/RE6500/Description
+ Package set compatible with the Linksys RE6500 board.
+endef
+$(eval $(call Profile,RE6500))
diff --git a/target/linux/ramips/mt7621/profiles/misc.mk b/target/linux/ramips/mt7621/profiles/misc.mk
new file mode 100644
index 0000000..9db0cd5
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/misc.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/PBR-M1
+ NAME:=PBR-M1 Device
+ FEATURES+=rtc
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
+ kmod-usb3-mt7621 kmod-rtc-pcf8563
+endef
+
+define Profile/PBR-M1/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,PBR-M1))
diff --git a/target/linux/ramips/mt7621/profiles/storylink.mk b/target/linux/ramips/mt7621/profiles/storylink.mk
new file mode 100644
index 0000000..9ca4a2f
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/storylink.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/SAP-G3200U3
+ NAME:=STORYLiNK SAP-G3200U3
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/SAP-G3200U3/Description
+ Package set compatible with the STORYLiNK SAP-G3200U3 board.
+endef
+$(eval $(call Profile,SAP-G3200U3))
diff --git a/target/linux/ramips/mt7621/profiles/zbt.mk b/target/linux/ramips/mt7621/profiles/zbt.mk
new file mode 100644
index 0000000..0134bb5
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/zbt.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZBT-WG2626
+ NAME:=ZBT-WG2626 Device
+ FEATURES+=rtc
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
+ kmod-usb3-mt7621
+endef
+
+define Profile/ZBT-WG2626/Description
+ Package set for ZBT-WG2626 device
+endef
+$(eval $(call Profile,ZBT-WG2626))