aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxa/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/pxa/profiles')
-rw-r--r--target/linux/pxa/profiles/100-Default.mk17
-rw-r--r--target/linux/pxa/profiles/200-Gumstix.mk17
2 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/pxa/profiles/100-Default.mk b/target/linux/pxa/profiles/100-Default.mk
new file mode 100644
index 0000000..566a43f
--- /dev/null
+++ b/target/linux/pxa/profiles/100-Default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:=
+endef
+
+define Profile/Default/Description
+ Default PXA Profile
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/pxa/profiles/200-Gumstix.mk b/target/linux/pxa/profiles/200-Gumstix.mk
new file mode 100644
index 0000000..f296414
--- /dev/null
+++ b/target/linux/pxa/profiles/200-Gumstix.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Gumstix
+ NAME:=Gumstix
+ PACKAGES:=uboot-pxa-gumstix
+endef
+
+define Profile/Atheros-ath5k/Description
+ Package set compatible with the Gumstix boards
+endef
+$(eval $(call Profile,Gumstix))
+