aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ppc40x/Makefile')
-rw-r--r--target/linux/ppc40x/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
new file mode 100644
index 0000000..fc85b03
--- /dev/null
+++ b/target/linux/ppc40x/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2008-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=ppc40x
+BOARDNAME:=AMCC/IBM PPC40x
+FEATURES:=squashfs broken
+CPU_TYPE:=405
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+KERNEL_PATCHVER:=3.18
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for AMCC/IBM PPC40x based boards.
+endef
+
+KERNELNAME:=uImage cuImage.magicbox cuImage.openrb
+
+$(eval $(call BuildTarget))