aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch b/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch
new file mode 100644
index 0000000..dde3140
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/ethernet/stmicro/stmmac/Kconfig
++++ b/drivers/net/ethernet/stmicro/stmmac/Kconfig
+@@ -20,7 +20,7 @@ config STMMAC_PLATFORM
+ ---help---
+ This selects the platform specific bus support for the stmmac driver.
+ This is the driver used on several SoCs:
+- STi, Allwinner, Amlogic Meson, Altera SOCFPGA.
++ STi, Allwinner, Amlogic Meson, Altera SOCFPGA and Oxnas.
+
+ If you have a controller with this interface, say Y or M here.
+
+--- a/drivers/net/ethernet/stmicro/stmmac/Makefile
++++ b/drivers/net/ethernet/stmicro/stmmac/Makefile
+@@ -5,8 +5,9 @@ stmmac-objs:= stmmac_main.o stmmac_ethto
+ mmc_core.o stmmac_hwtstamp.o stmmac_ptp.o $(stmmac-y)
+
+ obj-$(CONFIG_STMMAC_PLATFORM) += stmmac-platform.o
+-stmmac-platform-objs:= stmmac_platform.o dwmac-meson.o dwmac-sunxi.o \
+- dwmac-sti.o dwmac-socfpga.o dwmac-rk.o
++stmmac-platform-objs:= stmmac_platform.o dwmac-meson.o dwmac-oxnas.o \
++ dwmac-sunxi.o dwmac-sti.o dwmac-socfpga.o \
++ dwmac-rk.o
+
+ obj-$(CONFIG_STMMAC_PCI) += stmmac-pci.o
+ stmmac-pci-objs:= stmmac_pci.o