aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/patches-4.1/500-oxnas-sata.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/500-oxnas-sata.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch b/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch
new file mode 100644
index 0000000..8c59b21
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch
@@ -0,0 +1,26 @@
+--- a/drivers/ata/Kconfig
++++ b/drivers/ata/Kconfig
+@@ -402,6 +402,13 @@ config SATA_VITESSE
+
+ If unsure, say N.
+
++config SATA_OXNAS
++ tristate "PLXTECH NAS782X SATA support"
++ help
++ This option enables support for Nas782x Serial ATA controller.
++
++ If unsure, say N.
++
+ comment "PATA SFF controllers with BMDMA"
+
+ config PATA_ALI
+--- a/drivers/ata/Makefile
++++ b/drivers/ata/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
+ obj-$(CONFIG_SATA_ULI) += sata_uli.o
+ obj-$(CONFIG_SATA_VIA) += sata_via.o
+ obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
++obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
+
+ # SFF PATA w/ BMDMA
+ obj-$(CONFIG_PATA_ALI) += pata_ali.o