aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/310-oxnas-clocksource.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/patches-4.1/310-oxnas-clocksource.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/310-oxnas-clocksource.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/310-oxnas-clocksource.patch b/target/linux/oxnas/patches-4.1/310-oxnas-clocksource.patch
new file mode 100644
index 0000000..3699b7a
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/310-oxnas-clocksource.patch
@@ -0,0 +1,25 @@
+--- a/drivers/clocksource/Kconfig
++++ b/drivers/clocksource/Kconfig
+@@ -177,6 +177,12 @@ config VF_PIT_TIMER
+ help
+ Support for Period Interrupt Timer on Freescale Vybrid Family SoCs.
+
++config CLKSRC_RPS_TIMER
++ def_bool y if ARCH_OXNAS
++ select CLKSRC_MMIO
++ help
++ This option enables support for the oxnas rps timers.
++
+ config SYS_SUPPORTS_SH_CMT
+ bool
+
+--- a/drivers/clocksource/Makefile
++++ b/drivers/clocksource/Makefile
+@@ -39,6 +39,7 @@ obj-$(CONFIG_CLKSRC_EFM32) += time-efm32
+ obj-$(CONFIG_CLKSRC_EXYNOS_MCT) += exynos_mct.o
+ obj-$(CONFIG_CLKSRC_SAMSUNG_PWM) += samsung_pwm_timer.o
+ obj-$(CONFIG_FSL_FTM_TIMER) += fsl_ftm_timer.o
++obj-$(CONFIG_CLKSRC_RPS_TIMER) += oxnas_rps_timer.o
+ obj-$(CONFIG_VF_PIT_TIMER) += vf_pit_timer.o
+ obj-$(CONFIG_CLKSRC_QCOM) += qcom-timer.o
+ obj-$(CONFIG_MTK_TIMER) += mtk_timer.o