aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/omap24xx/profiles')
-rw-r--r--target/linux/omap24xx/profiles/100-n810.mk31
-rw-r--r--target/linux/omap24xx/profiles/110-n810-gui.mk22
2 files changed, 53 insertions, 0 deletions
diff --git a/target/linux/omap24xx/profiles/100-n810.mk b/target/linux/omap24xx/profiles/100-n810.mk
new file mode 100644
index 0000000..36f3086
--- /dev/null
+++ b/target/linux/omap24xx/profiles/100-n810.mk
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/n810-base
+ NAME:=Nokia n810 (base)
+ PACKAGES:= \
+ block-mount \
+ gpsd \
+ ip iw kmod-p54-spi wpa-supplicant \
+ dnsmasq dropbear \
+ pwrtray-backend \
+ kmod-fs-vfat kmod-fs-msdos \
+ kmod-input-evdev \
+ kmod-leds-gpio \
+ kmod-usb-tahvo kmod-usb-eth-gadget \
+ kmod-usb-net kmod-usb-net-cdc-ether kmod-usb-net-pegasus kmod-usb-net-rndis \
+ kmod-usb-storage kmod-usb-hid \
+ kmod-bluetooth kmod-bluetooth-hci-h4p bluez-utils bluez-hcidump \
+ kmod-n810bm maemo-kexec calvaria \
+ schedtool
+endef
+
+define Profile/n810-base/Description
+ Minimal package set for Nokia n810 hardware.
+endef
+$(eval $(call Profile,n810-base))
+
diff --git a/target/linux/omap24xx/profiles/110-n810-gui.mk b/target/linux/omap24xx/profiles/110-n810-gui.mk
new file mode 100644
index 0000000..9c3c5d0
--- /dev/null
+++ b/target/linux/omap24xx/profiles/110-n810-gui.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/n810-gui
+ $(call Profile/n810-base)
+ NAME:=Nokia n810 (GUI)
+ PACKAGES+= \
+ xserver-xorg xinit xauth xkeyboard-config xkbdata xterm \
+ xf86-video-omapfb xf86-input-tslib xf86-input-evdev \
+ openbox tint2 matchbox-keyboard \
+ pwrtray
+endef
+
+define Profile/n810-gui/Description
+ Graphical user interface package set for Nokia n810 hardware.
+endef
+$(eval $(call Profile,n810-gui))
+