aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mpc85xx/Makefile')
-rw-r--r--target/linux/mpc85xx/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
new file mode 100644
index 0000000..5f3ad6c
--- /dev/null
+++ b/target/linux/mpc85xx/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=mpc85xx
+BOARDNAME:=Freescale MPC85xx
+CPU_TYPE:=8540
+FEATURES:=squashfs
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS=generic p1020
+
+KERNEL_PATCHVER:=3.18
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNEL_IMAGES := zImage
+ifeq ($(SUBTARGET),generic)
+KERNEL_IMAGES += cuImage.tl-wdr4900-v1
+endif
+
+DEFAULT_PACKAGES += \
+ kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+ kmod-leds-gpio kmod-booke-wdt \
+ swconfig kmod-ath9k wpad-mini
+
+define Target/Description
+ Build images for the Freescale MPC85xx based boards.
+endef
+
+$(eval $(call BuildTarget))