aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mediatek/Makefile')
-rw-r--r--target/linux/mediatek/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mediatek/Makefile b/target/linux/mediatek/Makefile
new file mode 100644
index 0000000..d0b266b
--- /dev/null
+++ b/target/linux/mediatek/Makefile
@@ -0,0 +1,20 @@
+# Copyright (c) 2015 OpenWrt.org
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=mediatek
+BOARDNAME:=Mediatek Ralink ARM
+FEATURES:=squashfs
+CPU_TYPE:=cortex-a7
+MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+KERNEL_PATCHVER:=4.1
+
+KERNELNAME:=Image dtbs zImage
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+ kmod-leds-gpio kmod-gpio-button-hotplug swconfig
+
+$(eval $(call BuildTarget))