aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/harddisk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ixp4xx/harddisk')
-rw-r--r--target/linux/ixp4xx/harddisk/config-default20
-rw-r--r--target/linux/ixp4xx/harddisk/profiles/100-FSG3.mk20
-rw-r--r--target/linux/ixp4xx/harddisk/target.mk6
3 files changed, 46 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/harddisk/config-default b/target/linux/ixp4xx/harddisk/config-default
new file mode 100644
index 0000000..78e599c
--- /dev/null
+++ b/target/linux/ixp4xx/harddisk/config-default
@@ -0,0 +1,20 @@
+CONFIG_ATA=y
+CONFIG_BLK_DEV_SD=y
+CONFIG_CMDLINE="root=/dev/sda1 noinitrd console=ttyS0,115200"
+CONFIG_EXT4_FS=y
+CONFIG_JBD=y
+CONFIG_REISERFS_FS=y
+CONFIG_SATA_VIA=y
+CONFIG_USB=y
+CONFIG_USB_ARCH_HAS_EHCI=y
+CONFIG_USB_ARCH_HAS_HCD=y
+CONFIG_USB_ARCH_HAS_OHCI=y
+CONFIG_USB_EHCI_HCD=y
+# CONFIG_USB_EHCI_HCD_PLATFORM is not set
+CONFIG_USB_EHCI_ROOT_HUB_TT=y
+CONFIG_USB_EHCI_SPLIT_ISO=y
+CONFIG_USB_EHCI_TT_NEWSCHED=y
+CONFIG_USB_OHCI_HCD=y
+# CONFIG_USB_OHCI_HCD_PLATFORM is not set
+CONFIG_USB_OHCI_LITTLE_ENDIAN=y
+CONFIG_USB_STORAGE=y
diff --git a/target/linux/ixp4xx/harddisk/profiles/100-FSG3.mk b/target/linux/ixp4xx/harddisk/profiles/100-FSG3.mk
new file mode 100644
index 0000000..21f5e1f
--- /dev/null
+++ b/target/linux/ixp4xx/harddisk/profiles/100-FSG3.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FSG3
+ NAME:=Freecom FSG-3
+ PACKAGES:= \
+ kmod-ath5k \
+ kmod-usb-core kmod-usb-uhci kmod-usb2-pci kmod-usb-storage \
+ kmod-fs-ext4 kmod-fs-reiserfs
+endef
+
+define Profile/FSG3/Description
+ Package set optimized for the Freecom FSG-3
+endef
+$(eval $(call Profile,FSG3))
+
diff --git a/target/linux/ixp4xx/harddisk/target.mk b/target/linux/ixp4xx/harddisk/target.mk
new file mode 100644
index 0000000..c71065e
--- /dev/null
+++ b/target/linux/ixp4xx/harddisk/target.mk
@@ -0,0 +1,6 @@
+BOARDNAME:=Internal Hard-Disk
+
+define Target/Description
+ Build firmware images for ixp4xx based boards that boot directly from internal disk storage
+ (e.g : Freecom FSG-3, ...)
+endef