aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/Makefile')
-rw-r--r--target/linux/ipq806x/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ipq806x/Makefile b/target/linux/ipq806x/Makefile
new file mode 100644
index 0000000..45f83dd
--- /dev/null
+++ b/target/linux/ipq806x/Makefile
@@ -0,0 +1,22 @@
+# Copyright (c) 2013 The Linux Foundation. All rights reserved.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=ipq806x
+BOARDNAME:=Qualcomm Atheros IPQ806X
+FEATURES:=squashfs nand ubifs
+CPU_TYPE:=cortex-a7
+MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+KERNEL_PATCHVER:=3.18
+
+KERNELNAME:=zImage Image dtbs
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+ kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+ kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform
+
+
+$(eval $(call BuildTarget))