aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/imx6/Makefile')
-rw-r--r--target/linux/imx6/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
new file mode 100644
index 0000000..479b48e
--- /dev/null
+++ b/target/linux/imx6/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2013-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=imx6
+BOARDNAME:=Freescale i.MX 6
+FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz nand ubifs
+CPU_TYPE:=cortex-a9
+CPU_SUBTYPE:=neon
+MAINTAINER:=Luka Perkov <luka@openwrt.org>
+
+KERNEL_PATCHVER:=3.18
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage dtbs
+
+DEFAULT_PACKAGES += uboot-envtools
+
+$(eval $(call BuildTarget))