aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch')
-rw-r--r--target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch b/target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch
new file mode 100644
index 0000000..ac13c9e
--- /dev/null
+++ b/target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch
@@ -0,0 +1,29 @@
+--- a/usr/Makefile
++++ b/usr/Makefile
+@@ -53,6 +53,8 @@ ifneq ($(wildcard $(obj)/.initramfs_data
+ include $(obj)/.initramfs_data.cpio.d
+ endif
+
++deps_initramfs_sane := $(foreach v,$(deps_initramfs),$(if $(findstring :,$(v)),,$(v)))
++
+ quiet_cmd_initfs = GEN $@
+ cmd_initfs = $(initramfs) -o $@ $(ramfs-args) $(ramfs-input)
+
+@@ -61,14 +63,14 @@ targets := initramfs_data.cpio.gz initra
+ initramfs_data.cpio.lzo initramfs_data.cpio.lz4 \
+ initramfs_data.cpio
+ # do not try to update files included in initramfs
+-$(deps_initramfs): ;
++$(deps_initramfs_sane): ;
+
+-$(deps_initramfs): klibcdirs
++$(deps_initramfs_sane): klibcdirs
+ # We rebuild initramfs_data.cpio if:
+ # 1) Any included file is newer then initramfs_data.cpio
+ # 2) There are changes in which files are included (added or deleted)
+ # 3) If gen_init_cpio are newer than initramfs_data.cpio
+ # 4) arguments to gen_initramfs.sh changes
+-$(obj)/initramfs_data.cpio$(suffix_y): $(obj)/gen_init_cpio $(deps_initramfs) klibcdirs
++$(obj)/initramfs_data.cpio$(suffix_y): $(obj)/gen_init_cpio $(deps_initramfs_sane) klibcdirs
+ $(Q)$(initramfs) -l $(ramfs-input) > $(obj)/.initramfs_data.cpio.d
+ $(call if_changed,initfs)