aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch')
-rw-r--r--target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch b/target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch
new file mode 100644
index 0000000..d8c9492
--- /dev/null
+++ b/target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch
@@ -0,0 +1,31 @@
+--- a/drivers/leds/trigger/Kconfig
++++ b/drivers/leds/trigger/Kconfig
+@@ -119,4 +119,11 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_USBDEV
++ tristate "LED USB device Trigger"
++ depends on USB && LEDS_TRIGGERS
++ help
++ This allows LEDs to be controlled by the presence/activity of
++ an USB device. If unsure, say N.
++
+ endif # LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -64,3 +64,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
+ obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+--- a/drivers/leds/ledtrig-usbdev.c
++++ b/drivers/leds/ledtrig-usbdev.c
+@@ -24,7 +24,6 @@
+ #include <linux/list.h>
+ #include <linux/spinlock.h>
+ #include <linux/device.h>
+-#include <linux/sysdev.h>
+ #include <linux/timer.h>
+ #include <linux/ctype.h>
+ #include <linux/slab.h>