aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/cns3xxx/Makefile')
-rw-r--r--target/linux/cns3xxx/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/cns3xxx/Makefile b/target/linux/cns3xxx/Makefile
new file mode 100644
index 0000000..0b4432a
--- /dev/null
+++ b/target/linux/cns3xxx/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2010-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=cns3xxx
+BOARDNAME:=Cavium Networks Econa CNS3xxx
+FEATURES:=squashfs fpu gpio pcie usb usbgadget
+CPU_TYPE:=mpcore
+CPU_SUBTYPE:=vfp
+MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+KERNEL_PATCHVER:=3.18
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build images for Cavium Networks Econa CNS3xxx based boards,
+ eg. the Gateworks Laguna family
+endef
+
+KERNELNAME:=zImage
+
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
+
+$(eval $(call BuildTarget))