aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/legacy/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm47xx/legacy/profiles')
-rw-r--r--target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk20
-rw-r--r--target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk20
-rw-r--r--target/linux/brcm47xx/legacy/profiles/WGT634U.mk17
-rw-r--r--target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk17
4 files changed, 74 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
new file mode 100644
index 0000000..50d7770
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b43
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (b43, default)
+ PACKAGES:=kmod-b43 kmod-b43legacy
+endef
+
+define Profile/Broadcom-b43/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
+ b43legacy drivers and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-b43))
+
diff --git a/target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk b/target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk
new file mode 100644
index 0000000..6a4c5b0
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (wl, proprietary)
+ PACKAGES:=-wpad-mini kmod-brcm-wl-mini wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
+ wireless "wl" driver and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+
diff --git a/target/linux/brcm47xx/legacy/profiles/WGT634U.mk b/target/linux/brcm47xx/legacy/profiles/WGT634U.mk
new file mode 100644
index 0000000..ebe5e23
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/WGT634U.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WGT634U
+ NAME:=Netgear WGT634U
+ PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb2 kmod-ocf-ubsec-ssb
+endef
+
+define Profile/WGT634U/Description
+ Package set compatible with the Netgear WGT634U. Contains USB support
+endef
+$(eval $(call Profile,WGT634U))
+
diff --git a/target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk b/target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk
new file mode 100644
index 0000000..8c48483
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRTSL54GS
+ NAME:=Linksys WRTSL54GS
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage kmod-scsi-core kmod-fs-ext4 e2fsprogs kmod-b43
+endef
+
+define Profile/WRTSL54GS/Description
+ Package set compatible with the Linksys WRTSL54GS. Contains USB support
+endef
+$(eval $(call Profile,WRTSL54GS))
+