aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm47xx/Makefile')
-rw-r--r--target/linux/brcm47xx/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
new file mode 100644
index 0000000..e0c44c8
--- /dev/null
+++ b/target/linux/brcm47xx/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=brcm47xx
+BOARDNAME:=Broadcom BCM47xx/53xx (MIPS)
+FEATURES:=squashfs usb
+SUBTARGETS:=generic mips74k legacy
+MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+
+KERNEL_PATCHVER:=4.1
+
+include $(INCLUDE_DIR)/target.mk
+
+
+define Target/Description
+ Build firmware images for Broadcom based BCM47xx/53xx routers with MIPS CPU, *not* ARM.
+endef
+
+DEFAULT_PACKAGES += swconfig wpad-mini nvram otrx \
+ kmod-leds-gpio kmod-gpio-button-hotplug \
+ kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev
+
+$(eval $(call BuildTarget))