aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx/Makefile')
-rw-r--r--target/linux/bcm53xx/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/Makefile b/target/linux/bcm53xx/Makefile
new file mode 100644
index 0000000..68cfa63
--- /dev/null
+++ b/target/linux/bcm53xx/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=bcm53xx
+BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
+FEATURES:=squashfs nand usb pci pcie gpio
+MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+CPU_TYPE:=cortex-a9
+
+KERNEL_PATCHVER:=4.1
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
+endef
+
+KERNELNAME:=zImage dtbs
+
+DEFAULT_PACKAGES += swconfig wpad-mini nvram otrx \
+ kmod-gpio-button-hotplug \
+ kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
+
+$(eval $(call BuildTarget))