aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/au1000/modules.mk')
-rw-r--r--target/linux/au1000/modules.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/au1000/modules.mk b/target/linux/au1000/modules.mk
new file mode 100644
index 0000000..6b11053
--- /dev/null
+++ b/target/linux/au1000/modules.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2010-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/pcmcia-au1000
+ SUBMENU:=$(PCMCIA_MENU)
+ TITLE:=RMI/AMD Au1000 PCMCIA support
+ DEPENDS:=@TARGET_au1000 +kmod-pcmcia-core +kmod-pcmcia-rsrc
+ FILES:=$(LINUX_DIR)/drivers/pcmcia/db1xxx_ss.ko
+ KCONFIG:=CONFIG_PCMCIA_ALCHEMY_DEVBOARD
+ AUTOLOAD:=$(call AutoLoad,41,db1xxx_ss)
+endef
+
+$(eval $(call KernelPackage,pcmcia-au1000))