aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/nand/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/nand/profiles')
-rw-r--r--target/linux/ar71xx/nand/profiles/netgear.mk29
-rw-r--r--target/linux/ar71xx/nand/profiles/zyxel.mk18
2 files changed, 47 insertions, 0 deletions
diff --git a/target/linux/ar71xx/nand/profiles/netgear.mk b/target/linux/ar71xx/nand/profiles/netgear.mk
new file mode 100644
index 0000000..738aaba
--- /dev/null
+++ b/target/linux/ar71xx/nand/profiles/netgear.mk
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2009-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/R6100
+ NAME:=NETGEAR R6100
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/R6100/Description
+ Package set optimized for the NETGEAR R6100
+endef
+
+$(eval $(call Profile,R6100))
+
+
+define Profile/WNDR4300
+ NAME:=NETGEAR WNDR3700v4/WNDR4300
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNDR4300/Description
+ Package set optimized for the NETGEAR WNDR3700v4/WNDR4300
+endef
+
+$(eval $(call Profile,WNDR4300))
diff --git a/target/linux/ar71xx/nand/profiles/zyxel.mk b/target/linux/ar71xx/nand/profiles/zyxel.mk
new file mode 100644
index 0000000..ec813e5
--- /dev/null
+++ b/target/linux/ar71xx/nand/profiles/zyxel.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NBG6716
+ NAME:=Zyxel NBG 6716
+ PACKAGES:=kmod-rtc-pcf8563 kmod-ath10k
+endef
+
+define Profile/NBG6716/Description
+ Package set optimized for the Zyxel NBG 6716 Routers.
+endef
+
+$(eval $(call Profile,NBG6716))
+