aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/generic
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar7/generic')
-rw-r--r--target/linux/ar7/generic/config-default5
-rw-r--r--target/linux/ar7/generic/profiles/100-Annex-A.mk18
-rw-r--r--target/linux/ar7/generic/profiles/110-Annex-B.mk18
-rw-r--r--target/linux/ar7/generic/profiles/200-Texas.mk18
-rw-r--r--target/linux/ar7/generic/profiles/210-None.mk17
-rw-r--r--target/linux/ar7/generic/target.mk12
6 files changed, 88 insertions, 0 deletions
diff --git a/target/linux/ar7/generic/config-default b/target/linux/ar7/generic/config-default
new file mode 100644
index 0000000..10d46e9
--- /dev/null
+++ b/target/linux/ar7/generic/config-default
@@ -0,0 +1,5 @@
+CONFIG_AR7_TI=y
+# CONFIG_AR7_TYPE_AC49X is not set
+CONFIG_AR7_TYPE_TI=y
+# CONFIG_MTD_AC49X_PARTS is not set
+CONFIG_MTD_AR7_PARTS=y
diff --git a/target/linux/ar7/generic/profiles/100-Annex-A.mk b/target/linux/ar7/generic/profiles/100-Annex-A.mk
new file mode 100644
index 0000000..d8e549e
--- /dev/null
+++ b/target/linux/ar7/generic/profiles/100-Annex-A.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Annex-A
+ NAME:=Annex-A DSL firmware (default)
+ PACKAGES:=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
+ kmod-sangam-atm-annex-a
+endef
+
+define Profile/Annex-A/Description
+ Package set compatible with Annex-A DSL lines (most countries).
+endef
+$(eval $(call Profile,Annex-A))
+
diff --git a/target/linux/ar7/generic/profiles/110-Annex-B.mk b/target/linux/ar7/generic/profiles/110-Annex-B.mk
new file mode 100644
index 0000000..55de1fc
--- /dev/null
+++ b/target/linux/ar7/generic/profiles/110-Annex-B.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Annex-B
+ NAME:=Annex-B DSL firmware
+ PACKAGES:=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
+ kmod-sangam-atm-annex-b
+endef
+
+define Profile/Annex-B/Description
+ Package set compatible with Annex-B DSL lines (Germany).
+endef
+$(eval $(call Profile,Annex-B))
+
diff --git a/target/linux/ar7/generic/profiles/200-Texas.mk b/target/linux/ar7/generic/profiles/200-Texas.mk
new file mode 100644
index 0000000..7d868bd
--- /dev/null
+++ b/target/linux/ar7/generic/profiles/200-Texas.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Texas
+ NAME:=Texas Instruments WiFi (mac80211)
+ PACKAGES:=kmod-acx-mac80211
+endef
+
+define Profile/Texas/Description
+ Package set compatible with hardware using Texas Instruments WiFi cards
+ using the mac80211 driver.
+endef
+$(eval $(call Profile,Texas))
+
diff --git a/target/linux/ar7/generic/profiles/210-None.mk b/target/linux/ar7/generic/profiles/210-None.mk
new file mode 100644
index 0000000..2fcfacd
--- /dev/null
+++ b/target/linux/ar7/generic/profiles/210-None.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+ NAME:=No WiFi
+ PACKAGES:=
+endef
+
+define Profile/None/Description
+ Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+
diff --git a/target/linux/ar7/generic/target.mk b/target/linux/ar7/generic/target.mk
new file mode 100644
index 0000000..8b5350e
--- /dev/null
+++ b/target/linux/ar7/generic/target.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+
+SUBTARGET:=generic
+BOARDNAME:=Texas Instruments AR7 boards
+
+DEFAULT_PACKAGES+= kmod-mac80211 kmod-acx-mac80211 wpad-mini
+
+define Target/Description
+ Build firmware images for TI AR7 based routers.
+endef