aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.18/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/patches-3.18/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-3.18/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.18/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-3.18/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000..627afc1
--- /dev/null
+++ b/target/linux/adm5120/patches-3.18/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -508,4 +508,12 @@ config LEDS_VERSATILE
+ comment "LED Triggers"
+ source "drivers/leds/trigger/Kconfig"
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -65,3 +65,4 @@ obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o