aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/usign/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/system/usign/Makefile')
-rw-r--r--package/system/usign/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/package/system/usign/Makefile b/package/system/usign/Makefile
new file mode 100644
index 0000000..713bb93
--- /dev/null
+++ b/package/system/usign/Makefile
@@ -0,0 +1,43 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=usign
+PKG_VERSION:=2015-05-08
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.openwrt.org/project/usign.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=cf8dcdb8a4e874c77f3e9a8e9b643e8c17b19131
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+CMAKE_INSTALL:=1
+PKG_CHECK_FORMAT_SECURITY:=1
+PKG_USE_MIPS16:=0
+
+PKG_LICENSE:=ISC
+PKG_LICENSE_FILES:=
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/usign
+ SECTION:=base
+ CATEGORY:=Base system
+ DEPENDS:=+libubox
+ TITLE:=OpenWrt signature verification utility
+endef
+
+CMAKE_OPTIONS += \
+ -DUSE_LIBUBOX=on
+
+define Package/usign/install
+ $(INSTALL_DIR) $(1)/usr/bin
+
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/usign $(1)/usr/bin
+ ln -s usign $(1)/usr/bin/signify
+endef
+
+$(eval $(call BuildPackage,usign))
+$(eval $(call HostBuild))