aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/wpan-tools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/wpan-tools/Makefile')
-rw-r--r--package/network/utils/wpan-tools/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/package/network/utils/wpan-tools/Makefile b/package/network/utils/wpan-tools/Makefile
new file mode 100644
index 0000000..6c2559d
--- /dev/null
+++ b/package/network/utils/wpan-tools/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wpan-tools
+PKG_VERSION:=0.5
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://wpan.cakelab.org/releases/
+PKG_MD5SUM:=6226df405a98c13ec41bf4d1f0777d6b
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/wpan-tools
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=cfg802154 interface configuration utility
+ URL:=http://wpan.cakelab.org/
+ DEPENDS:= +libnl
+endef
+
+define Build/Configure
+ $(call Build/Configure/Default)
+endef
+
+define Package/wpan-tools/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iwpan $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,wpan-tools))