aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/popt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/popt/Makefile')
-rw-r--r--package/libs/popt/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/package/libs/popt/Makefile b/package/libs/popt/Makefile
new file mode 100644
index 0000000..b31b311
--- /dev/null
+++ b/package/libs/popt/Makefile
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=popt
+PKG_VERSION:=1.16
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://rpm5.org/files/popt/
+PKG_MD5SUM:=3743beefa3dd6247a73f8f7a32c14c33
+PKG_LICENSE:=MIT
+
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=autogen.sh aclocal.m4
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS += $(FPIC)
+
+define Package/libpopt
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A command line option parsing library
+ URL:=http://rpm5.org/files/popt/
+endef
+
+define Build/Configure
+ $(call Build/Configure/Default, \
+ --enable-shared \
+ --enable-static \
+ )
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/popt.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/popt.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libpopt/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call RequireCommand,xgettext, \
+ $(PKG_NAME) requires the GNU gettext development package installed on the local system to build. \
+))
+
+$(eval $(call BuildPackage,libpopt))
+