aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libnfnetlink
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libnfnetlink')
-rw-r--r--package/libs/libnfnetlink/Makefile71
-rw-r--r--package/libs/libnfnetlink/patches/100-missing_include.patch20
2 files changed, 91 insertions, 0 deletions
diff --git a/package/libs/libnfnetlink/Makefile b/package/libs/libnfnetlink/Makefile
new file mode 100644
index 0000000..861c604
--- /dev/null
+++ b/package/libs/libnfnetlink/Makefile
@@ -0,0 +1,71 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnfnetlink
+PKG_VERSION:=1.0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:= \
+ http://www.netfilter.org/projects/libnfnetlink/files/ \
+ ftp://ftp.netfilter.org/pub/libnfnetlink/ \
+ http://mirrors.evolva.ro/netfilter.org/libnfnetlink/
+PKG_MD5SUM:=98927583d2016a9fb1936fed992e2c5e
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_LICENSE:=GPL-2.0+
+
+PKG_FIXUP:=autoreconf
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnfnetlink
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A low-level library for netfilter related kernel/userspace communication
+ URL:=http://netfilter.org/projects/libnfnetlink/
+endef
+
+define Package/libnfnetlink/description
+ libnfnetlink is is the low-level library for netfilter related kernel/userspace communication.
+ It provides a generic messaging infrastructure for in-kernel netfilter subsystems
+ (such as nfnetlink_log, nfnetlink_queue, nfnetlink_conntrack) and their respective users
+ and/or management tools in userspace.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-static \
+ --enable-shared
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/libnfnetlink
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/libnfnetlink/{libnfnetlink,linux_nfnetlink,linux_nfnetlink_compat}.h \
+ $(1)/usr/include/libnfnetlink/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.{a,so*} \
+ $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnfnetlink.pc \
+ $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libnfnetlink/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.so.* \
+ $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnfnetlink))
diff --git a/package/libs/libnfnetlink/patches/100-missing_include.patch b/package/libs/libnfnetlink/patches/100-missing_include.patch
new file mode 100644
index 0000000..163307d
--- /dev/null
+++ b/package/libs/libnfnetlink/patches/100-missing_include.patch
@@ -0,0 +1,20 @@
+--- a/include/libnfnetlink/libnfnetlink.h
++++ b/include/libnfnetlink/libnfnetlink.h
+@@ -15,6 +15,7 @@
+ #define aligned_u64 unsigned long long __attribute__((aligned(8)))
+ #endif
+
++#include <sys/types.h>
+ #include <sys/socket.h> /* for sa_family_t */
+ #include <linux/netlink.h>
+ #include <libnfnetlink/linux_nfnetlink.h>
+--- a/include/libnfnetlink/linux_nfnetlink.h
++++ b/include/libnfnetlink/linux_nfnetlink.h
+@@ -1,6 +1,6 @@
+ #ifndef _NFNETLINK_H
+ #define _NFNETLINK_H
+-#include <linux/types.h>
++#include <sys/types.h>
+ #include <libnfnetlink/linux_nfnetlink_compat.h>
+
+ enum nfnetlink_groups {