aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/strace
diff options
context:
space:
mode:
Diffstat (limited to 'package/devel/strace')
-rw-r--r--package/devel/strace/Makefile58
-rw-r--r--package/devel/strace/patches/001-upstream-musl_includes.patch53
2 files changed, 111 insertions, 0 deletions
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
new file mode 100644
index 0000000..76c140a
--- /dev/null
+++ b/package/devel/strace/Makefile
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=strace
+
+PKG_VERSION:=4.10
+PKG_RELEASE:=1
+PKG_MD5SUM:=107a5be455493861189e9b57a3a51912
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+
+PKG_LICENSE:=BSD-3c
+PKG_LICENSE_FILES:=COPYRIGHT
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+HOST_CFLAGS += -I$(LINUX_DIR)/user_headers/include
+
+CONFIGURE_VARS+= \
+ LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
+ CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \
+ CFLAGS_FOR_BUILD="$(HOST_CFLAGS)" \
+ CC_FOR_BUILD="$(HOST_CC)"
+
+define Package/strace
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=System call tracer
+ URL:=http://strace.sourceforge.net/
+endef
+
+define Package/strace/description
+A useful diagnostic, instructional, and debugging tool. Allows you to track what
+system calls a program makes while it is running.
+endef
+
+MAKE_FLAGS := \
+ CCOPT="$(TARGET_CFLAGS)"
+
+define Package/strace/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/strace $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,strace))
diff --git a/package/devel/strace/patches/001-upstream-musl_includes.patch b/package/devel/strace/patches/001-upstream-musl_includes.patch
new file mode 100644
index 0000000..a35d7fd
--- /dev/null
+++ b/package/devel/strace/patches/001-upstream-musl_includes.patch
@@ -0,0 +1,53 @@
+--- a/evdev.c
++++ b/evdev.c
+@@ -28,6 +28,8 @@
+
+ #include "defs.h"
+
++#include <linux/ioctl.h>
++
+ #ifdef HAVE_LINUX_INPUT_H
+ #include <linux/input.h>
+ #include "xlat/evdev_abs.h"
+--- a/ioctl.c
++++ b/ioctl.c
+@@ -29,7 +29,7 @@
+ */
+
+ #include "defs.h"
+-#include <asm/ioctl.h>
++#include <linux/ioctl.h>
+ #include "xlat/ioctl_dirs.h"
+
+ #ifdef HAVE_LINUX_INPUT_H
+--- a/ioctlsort.c
++++ b/ioctlsort.c
+@@ -33,7 +33,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <asm/ioctl.h>
++#include <linux/ioctl.h>
+
+ struct ioctlent {
+ const char *info;
+--- a/mknod.c
++++ b/mknod.c
+@@ -1,6 +1,7 @@
+ #include "defs.h"
+
+ #include <fcntl.h>
++#include <sys/stat.h>
+
+ #ifdef MAJOR_IN_SYSMACROS
+ # include <sys/sysmacros.h>
+--- a/printmode.c
++++ b/printmode.c
+@@ -1,6 +1,7 @@
+ #include "defs.h"
+
+ #include <fcntl.h>
++#include <sys/stat.h>
+
+ #include "xlat/modetypes.h"
+