aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kobs-ng
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/kobs-ng')
-rw-r--r--package/boot/kobs-ng/Makefile45
-rw-r--r--package/boot/kobs-ng/patches/001-fix-mtd-defines.patch76
-rw-r--r--package/boot/kobs-ng/patches/002-add-init-size-param.patch42
-rw-r--r--package/boot/kobs-ng/patches/003-missing_include.patch20
-rw-r--r--package/boot/kobs-ng/patches/004-gnu_source.patch10
5 files changed, 193 insertions, 0 deletions
diff --git a/package/boot/kobs-ng/Makefile b/package/boot/kobs-ng/Makefile
new file mode 100644
index 0000000..c43fa19
--- /dev/null
+++ b/package/boot/kobs-ng/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2013-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=kobs-ng
+PKG_VERSION:=3.0.35-4.0.0
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://repository.timesys.com/buildsources/k/kobs-ng/kobs-ng-$(PKG_VERSION)/
+PKG_MD5SUM:=26104c577f59a6b81782a5bd16aadd82
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/kobs-ng
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Application for writing bootstreams to NAND flash
+ DEPENDS:=@TARGET_imx6
+endef
+
+define Package/kobs-ng/description
+ The kobs-ng application writes a bootstream to NAND flash with the proper
+ FCB/DBBT headers and replicated streams.
+endef
+
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ echo "const char* git_sha = \"$(PKG_VERSION)\";" > $(PKG_BUILD_DIR)/autoversion.h
+endef
+
+define Package/kobs-ng/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/kobs-ng $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,kobs-ng))
diff --git a/package/boot/kobs-ng/patches/001-fix-mtd-defines.patch b/package/boot/kobs-ng/patches/001-fix-mtd-defines.patch
new file mode 100644
index 0000000..6fdc735
--- /dev/null
+++ b/package/boot/kobs-ng/patches/001-fix-mtd-defines.patch
@@ -0,0 +1,76 @@
+From: Paul B. Henson <henson@acm.org>
+
+Newer kernel headers renamed mtd mode defines and no longer support
+MEMSETOOBSEL. Allow code to work with both older and newer kernel
+versions.
+
+Signed-off-by: Paul B. Henson <henson@acm.org>
+---
+
+http://git.buildroot.net/buildroot/plain/package/kobs-ng/kobs-ng-fix-mtd-defines.patch
+
+--- a/src/mtd.c
++++ b/src/mtd.c
+@@ -852,8 +852,11 @@ void mtd_close(struct mtd_data *md)
+ mp = &md->part[i];
+
+ if (mp->fd != -1) {
++/* Newer kernels dropped MEMSETOOBSEL */
++#ifdef MEMSETOOBSEL
+ (void)ioctl(mp->fd, MEMSETOOBSEL,
+ &mp->old_oobinfo);
++#endif
+ close(mp->fd);
+ }
+
+@@ -896,6 +899,8 @@ int mtd_set_ecc_mode(struct mtd_data *md
+ continue;
+ }
+
++/* Newer kernels dropped MEMSETOOBSEL */
++#ifdef MEMSETOOBSEL
+ if (r == -ENOTTY) {
+ r = ioctl(mp->fd, MEMSETOOBSEL, &mp->old_oobinfo);
+ if (r != 0) {
+@@ -904,6 +909,7 @@ int mtd_set_ecc_mode(struct mtd_data *md
+ }
+ mp->oobinfochanged = 0;
+ }
++#endif
+ } else {
+ r = ioctl(mp->fd, MTDFILEMODE, (void *)MTD_MODE_RAW);
+ if (r != 0 && r != -ENOTTY) {
+@@ -911,6 +917,8 @@ int mtd_set_ecc_mode(struct mtd_data *md
+ continue;
+ }
+
++/* Newer kernels dropped MEMSETOOBSEL */
++#ifdef MEMSETOOBSEL
+ if (r == -ENOTTY) {
+ r = ioctl(mp->fd, MEMSETOOBSEL, &none_oobinfo);
+ if (r != 0) {
+@@ -920,6 +928,7 @@ int mtd_set_ecc_mode(struct mtd_data *md
+ mp->oobinfochanged = 1;
+ } else
+ mp->oobinfochanged = 2;
++#endif
+ }
+
+ mp->ecc = ecc;
+--- a/src/mtd.h
++++ b/src/mtd.h
+@@ -31,6 +31,14 @@
+ #include "BootControlBlocks.h"
+ #include "rom_nand_hamming_code_ecc.h"
+
++// Newer kernel headers renamed define
++#ifndef MTD_MODE_NORMAL
++#define MTD_MODE_NORMAL MTD_FILE_MODE_NORMAL
++#endif
++#ifndef MTD_MODE_RAW
++#define MTD_MODE_RAW MTD_FILE_MODE_RAW
++#endif
++
+ //------------------------------------------------------------------------------
+ // Re-definitions of true and false, because the standard ones aren't good
+ // enough?
diff --git a/package/boot/kobs-ng/patches/002-add-init-size-param.patch b/package/boot/kobs-ng/patches/002-add-init-size-param.patch
new file mode 100644
index 0000000..e0e89b2
--- /dev/null
+++ b/package/boot/kobs-ng/patches/002-add-init-size-param.patch
@@ -0,0 +1,42 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -94,6 +94,7 @@ void usage(void)
+ " [KOBS] boot structures config options\n"
+ " --chip_0_device_path=<path> .......... Device of boot (default /dev/mtd0)\n"
+ " --chip_1_device_path=<path> .......... The second chip in case of multichip NAND\n"
++ " --chip_0_size=<size> ................. Override size of chip_0 device\n"
+ " --search_exponent=<value> ............ NCB field (default 2)\n"
+ " --data_setup_time=<value> ............ NCB field (default 80)\n"
+ " --data_hold_time=<value> ............. NCB field (default 60)\n"
+--- a/src/mtd.c
++++ b/src/mtd.c
+@@ -716,6 +716,11 @@ struct mtd_data *mtd_open(const struct m
+ goto out;
+ }
+
++ /* override MTD size */
++ if (md->cfg.chip_0_size) {
++ miu->size = md->cfg.chip_0_size;
++ }
++
+ /* verify it's a nand */
+ if (miu->type != MTD_NANDFLASH) {
+ fprintf(stderr, "mtd: device %s not NAND\n", mp->name);
+@@ -2914,7 +2919,7 @@ static const struct {
+ } mtd_int_args[] = {
+ ARG_IGNORE(chip_count),
+ ARG_IGNORE(chip_0_offset),
+- ARG_IGNORE(chip_0_size),
++ ARG(chip_0_size),
+ ARG_IGNORE(chip_1_offset),
+ ARG_IGNORE(chip_1_size),
+ ARG(search_exponent),
+@@ -3107,7 +3112,7 @@ void mtd_cfg_dump(struct mtd_config *cfg
+ // Pd(chip_count);
+ Ps(chip_0_device_path);
+ // Pd(chip_0_offset);
+-// Pd(chip_0_size);
++ Pd(chip_0_size);
+ Ps(chip_1_device_path);
+ // Pd(chip_1_offset);
+ // Pd(chip_1_size);
diff --git a/package/boot/kobs-ng/patches/003-missing_include.patch b/package/boot/kobs-ng/patches/003-missing_include.patch
new file mode 100644
index 0000000..b91c050
--- /dev/null
+++ b/package/boot/kobs-ng/patches/003-missing_include.patch
@@ -0,0 +1,20 @@
+--- a/src/mtd.c
++++ b/src/mtd.c
+@@ -28,6 +28,7 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <stddef.h>
+ #include <fcntl.h>
+ #include <ctype.h>
+ #include <errno.h>
+--- a/src/mtd.h
++++ b/src/mtd.h
+@@ -27,6 +27,7 @@
+
+ #include <mtd/mtd-user.h>
+ #include <endian.h>
++#include <fcntl.h>
+
+ #include "BootControlBlocks.h"
+ #include "rom_nand_hamming_code_ecc.h"
diff --git a/package/boot/kobs-ng/patches/004-gnu_source.patch b/package/boot/kobs-ng/patches/004-gnu_source.patch
new file mode 100644
index 0000000..3e94c92
--- /dev/null
+++ b/package/boot/kobs-ng/patches/004-gnu_source.patch
@@ -0,0 +1,10 @@
+--- a/src/plat_boot_config.c
++++ b/src/plat_boot_config.c
+@@ -18,6 +18,7 @@
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ */
+
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>