aboutsummaryrefslogtreecommitdiffstats
path: root/config
diff options
context:
space:
mode:
Diffstat (limited to 'config')
-rw-r--r--config/Config-build.in292
-rw-r--r--config/Config-devel.in111
-rw-r--r--config/Config-images.in315
-rw-r--r--config/Config-kernel.in553
4 files changed, 1271 insertions, 0 deletions
diff --git a/config/Config-build.in b/config/Config-build.in
new file mode 100644
index 0000000..2523a18
--- /dev/null
+++ b/config/Config-build.in
@@ -0,0 +1,292 @@
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+menu "Global build settings"
+
+ config ALL_KMODS
+ bool "Select all kernel module packages by default"
+ default ALL
+
+ config ALL
+ bool "Select all userspace packages by default"
+ default n
+
+ config SIGNED_PACKAGES
+ bool "Cryptographically signed package lists"
+ default y
+
+ comment "General build options"
+
+ config DISPLAY_SUPPORT
+ bool "Show packages that require graphics support (local or remote)"
+ default n
+
+ config BUILD_PATENTED
+ default y
+ bool "Compile with support for patented functionality"
+ help
+ When this option is disabled, software which provides patented functionality
+ will not be built. In case software provides optional support for patented
+ functionality, this optional support will get disabled for this package.
+
+ config BUILD_NLS
+ default n
+ bool "Compile with full language support"
+ help
+ When this option is enabled, packages are built with the full versions of
+ iconv and GNU gettext instead of the default OpenWrt stubs. If uClibc is
+ used, it is also built with locale support.
+
+ config SHADOW_PASSWORDS
+ bool
+ prompt "Enable shadow password support"
+ default y
+ help
+ Enable shadow password support.
+
+ config CLEAN_IPKG
+ bool
+ prompt "Remove ipkg/opkg status data files in final images"
+ default n
+ help
+ This removes all ipkg/opkg status data files from the target directory
+ before building the root filesystem.
+
+ config COLLECT_KERNEL_DEBUG
+ bool
+ prompt "Collect kernel debug information"
+ select KERNEL_DEBUG_INFO
+ default n
+ help
+ This collects debugging symbols from the kernel and all compiled modules.
+ Useful for release builds, so that kernel issues can be debugged offline
+ later.
+
+ comment "Kernel build options"
+
+ source "config/Config-kernel.in"
+
+ comment "Package build options"
+
+ config DEBUG
+ bool
+ prompt "Compile packages with debugging info"
+ default n
+ help
+ Adds -g3 to the CFLAGS.
+
+ config IPV6
+ bool
+ prompt "Enable IPv6 support in packages"
+ default y
+ help
+ Enables IPv6 support in kernel (builtin) and packages.
+
+ config PKG_BUILD_PARALLEL
+ bool
+ prompt "Compile certain packages parallelized"
+ default y
+ help
+ This adds a -jX option to certain packages that are known to behave well
+ for parallel build. By default, the package make processes use the main
+ jobserver, in which case this option only takes effect when you add -jX
+ to the make command.
+
+ If you are unsure, select N.
+
+ config PKG_BUILD_USE_JOBSERVER
+ bool
+ prompt "Use top-level make jobserver for packages"
+ depends on PKG_BUILD_PARALLEL
+ default y
+ help
+ This passes the main make process jobserver fds to package builds,
+ enabling full parallelization across different packages.
+
+ Note that disabling this may overcommit CPU resources depending on the
+ -j level of the main make process, the number of package submake jobs
+ selected below and the number of actual CPUs present.
+ Example: If the main make is passed a -j4 and the submake -j
+ is also set to 4, we may end up with 16 parallel make processes
+ in the worst case.
+
+ config PKG_BUILD_JOBS
+ int
+ prompt "Number of package submake jobs (2-512)"
+ range 2 512
+ default 2
+ depends on PKG_BUILD_PARALLEL && !PKG_BUILD_USE_JOBSERVER
+ help
+ The number of jobs (-jX) to pass to packages submake.
+
+ config PKG_DEFAULT_PARALLEL
+ bool
+ prompt "Parallelize the default package build rule (May break build)"
+ depends on PKG_BUILD_PARALLEL
+ depends on BROKEN
+ default n
+ help
+ Always set the default package build rules to parallel build.
+
+ WARNING: This may break build or kill your cat, as it builds packages
+ with multiple jobs that are probably not tested in a parallel build
+ environment.
+
+ Only say Y if you don't mind fixing broken packages. Before reporting
+ build bugs, set this to N and re-run the build.
+
+ comment "Stripping options"
+
+ choice
+ prompt "Binary stripping method"
+ default USE_STRIP if EXTERNAL_TOOLCHAIN
+ default USE_STRIP if USE_GLIBC || USE_MUSL
+ default USE_SSTRIP
+ help
+ Select the binary stripping method you wish to use.
+
+ config NO_STRIP
+ bool "none"
+ help
+ This will install unstripped binaries (useful for native
+ compiling/debugging).
+
+ config USE_STRIP
+ bool "strip"
+ help
+ This will install binaries stripped using strip from binutils.
+
+
+ config USE_SSTRIP
+ bool "sstrip"
+ depends on !DEBUG
+ depends on !USE_GLIBC
+ help
+ This will install binaries stripped using sstrip.
+ endchoice
+
+ config STRIP_ARGS
+ string
+ prompt "Strip arguments"
+ depends on USE_STRIP
+ default "--strip-unneeded --remove-section=.comment --remove-section=.note" if DEBUG
+ default "--strip-all"
+ help
+ Specifies arguments passed to the strip command when stripping binaries.
+
+ config STRIP_KERNEL_EXPORTS
+ bool "Strip unnecessary exports from the kernel image"
+ help
+ Reduces kernel size by stripping unused kernel exports from the kernel
+ image. Note that this might make the kernel incompatible with any kernel
+ modules that were not selected at the time the kernel image was created.
+
+ config USE_MKLIBS
+ bool "Strip unnecessary functions from libraries"
+ help
+ Reduces libraries to only those functions that are necessary for using all
+ selected packages (including those selected as <M>). Note that this will
+ make the system libraries incompatible with most of the packages that are
+ not selected during the build process.
+
+ choice
+ prompt "Preferred standard C++ library"
+ default USE_LIBSTDCXX if USE_GLIBC
+ default USE_UCLIBCXX
+ help
+ Select the preferred standard C++ library for all packages that support this.
+
+ config USE_UCLIBCXX
+ bool "uClibc++"
+
+ config USE_LIBSTDCXX
+ bool "libstdc++"
+ endchoice
+
+ comment "Hardening build options"
+
+ config PKG_CHECK_FORMAT_SECURITY
+ bool
+ prompt "Enable gcc format-security"
+ default y
+ help
+ Add -Wformat -Werror=format-security to the CFLAGS. You can disable
+ this per package by adding PKG_CHECK_FORMAT_SECURITY:=0 in the package
+ Makefile.
+
+ choice
+ prompt "User space Stack-Smashing Protection"
+ depends on USE_MUSL
+ default PKG_CC_STACKPROTECTOR_REGULAR
+ help
+ Enable GCC Stack Smashing Protection (SSP) for userspace applications
+ config PKG_CC_STACKPROTECTOR_NONE
+ bool "None"
+ config PKG_CC_STACKPROTECTOR_REGULAR
+ bool "Regular"
+ select SSP_SUPPORT if !USE_MUSL
+ depends on KERNEL_CC_STACKPROTECTOR_REGULAR
+ config PKG_CC_STACKPROTECTOR_STRONG
+ bool "Strong"
+ select SSP_SUPPORT if !USE_MUSL
+ depends on GCC_VERSION_5
+ depends on KERNEL_CC_STACKPROTECTOR_STRONG
+ endchoice
+
+ choice
+ prompt "Kernel space Stack-Smashing Protection"
+ default KERNEL_CC_STACKPROTECTOR_REGULAR
+ depends on USE_MUSL || !(x86_64 || i386)
+ help
+ Enable GCC Stack-Smashing Protection (SSP) for the kernel
+ config KERNEL_CC_STACKPROTECTOR_NONE
+ bool "None"
+ config KERNEL_CC_STACKPROTECTOR_REGULAR
+ bool "Regular"
+ config KERNEL_CC_STACKPROTECTOR_STRONG
+ depends on GCC_VERSION_5
+ bool "Strong"
+ endchoice
+
+ choice
+ prompt "Enable buffer-overflows detection (FORTIFY_SOURCE)"
+ default PKG_FORTIFY_SOURCE_1
+ help
+ Enable the _FORTIFY_SOURCE macro which introduces additional
+ checks to detect buffer-overflows in the following standard library
+ functions: memcpy, mempcpy, memmove, memset, strcpy, stpcpy,
+ strncpy, strcat, strncat, sprintf, vsprintf, snprintf, vsnprintf,
+ gets. "Conservative" (_FORTIFY_SOURCE set to 1) only introduces
+ checks that shouldn't change the behavior of conforming programs,
+ while "aggressive" (_FORTIFY_SOURCES set to 2) some more checking is
+ added, but some conforming programs might fail.
+ config PKG_FORTIFY_SOURCE_NONE
+ bool "None"
+ config PKG_FORTIFY_SOURCE_1
+ bool "Conservative"
+ config PKG_FORTIFY_SOURCE_2
+ bool "Aggressive"
+ endchoice
+
+ choice
+ prompt "Enable RELRO protection"
+ default PKG_RELRO_FULL
+ help
+ Enable a link-time protection known as RELRO (Relocation Read Only)
+ which helps to protect from certain type of exploitation techniques
+ altering the content of some ELF sections. "Partial" RELRO makes the
+ .dynamic section not writeable after initialization, introducing
+ almost no performance penalty, while "full" RELRO also marks the GOT
+ as read-only at the cost of initializing all of it at startup.
+ config PKG_RELRO_NONE
+ bool "None"
+ config PKG_RELRO_PARTIAL
+ bool "Partial"
+ config PKG_RELRO_FULL
+ bool "Full"
+ endchoice
+
+endmenu
diff --git a/config/Config-devel.in b/config/Config-devel.in
new file mode 100644
index 0000000..d096c18
--- /dev/null
+++ b/config/Config-devel.in
@@ -0,0 +1,111 @@
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+menuconfig DEVEL
+ bool "Advanced configuration options (for developers)"
+ default n
+
+ config BROKEN
+ bool "Show broken platforms / packages" if DEVEL
+ default n
+
+ config BINARY_FOLDER
+ string "Binary folder" if DEVEL
+ default ""
+ help
+ Store built firmware images and filesystem images in this directory.
+ If not set, uses './bin/$(BOARD)'
+
+ config DOWNLOAD_FOLDER
+ string "Download folder" if DEVEL
+ default ""
+ help
+ Store downloaded source bundles in this directory.
+ If not set then defaults to './dl', which is removed by operations such as
+ 'git clean -xdf' or 'make distclean'.
+ This option is useful if you have a low bandwidth Internet connection, and by
+ setting a path outside the OpenWrt tree downloads will be saved.
+
+ config LOCALMIRROR
+ string "Local mirror for source packages" if DEVEL
+ default ""
+
+ config AUTOREBUILD
+ bool "Automatic rebuild of packages" if DEVEL
+ default y
+ help
+ Automatically rebuild packages when their files change.
+
+ config BUILD_SUFFIX
+ string "Build suffix to append to the target BUILD_DIR variable" if DEVEL
+ default ""
+ help
+ Build suffix to append to the BUILD_DIR variable, i.e: './build_dir/{target-build-dir}_$(BUILD_SUFFIX)'.
+ This allows you to switch to a different .config whilst retaining all the build
+ objects generated by the first .config
+
+ config TARGET_ROOTFS_DIR
+ string "Override the default TARGET_ROOTFS_DIR variable" if DEVEL
+ default ""
+ help
+ Override the default TARGET_ROOTFS_DIR variable content $(BUILD_DIR) with
+ custom path. Use this option to re-define the location of the target
+ root filesystem directory.
+
+ config CCACHE
+ bool "Use ccache" if DEVEL
+ default n
+ help
+ Compiler cache; see http://ccache.samba.org/.
+
+ config EXTERNAL_KERNEL_TREE
+ string "Use external kernel tree" if DEVEL
+ default ""
+
+ config KERNEL_GIT_CLONE_URI
+ string "Enter git repository to clone" if DEVEL
+ default ""
+ help
+ Enter the full git repository path i.e.:
+ git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git
+ This will create a git clone of the kernel in your build directory.
+
+ config KERNEL_GIT_LOCAL_REPOSITORY
+ string "Enter path to local reference repository" if DEVEL
+ depends on (KERNEL_GIT_CLONE_URI != "")
+ default ""
+ help
+ Enter a full pathname to a local reference git repository.
+ In this instance, the --reference option of git clone will
+ be used thus creating a quick local clone of your repo.
+
+ config KERNEL_GIT_BRANCH
+ string "Enter git branch to clone" if DEVEL
+ depends on (KERNEL_GIT_CLONE_URI != "")
+ default ""
+ help
+ Enter the branch name to checkout after cloning the git repository.
+ In this instance, the --branch option of git clone will be used.
+ If unused, the clone's repository HEAD will be checked-out.
+
+ config BUILD_LOG
+ bool "Enable log files during build process" if DEVEL
+ help
+ If enabled, log files will be written to the ./log directory.
+
+ config SRC_TREE_OVERRIDE
+ bool "Enable package source tree override" if DEVEL
+ help
+ If enabled, you can force a package to use a git tree as source
+ code instead of the normal tarball. Create a symlink 'git-src'
+ in the package directory, pointing to the .git tree that you want
+ to pull the source code from.
+
+ config EXTRA_OPTIMIZATION
+ string "Additional compiler options" if DEVEL
+ default "-fno-caller-saves"
+ help
+ Extra target-independent optimizations to use when building for the target.
diff --git a/config/Config-images.in b/config/Config-images.in
new file mode 100644
index 0000000..a60dd50
--- /dev/null
+++ b/config/Config-images.in
@@ -0,0 +1,315 @@
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+menu "Target Images"
+
+ menuconfig TARGET_ROOTFS_INITRAMFS
+ bool "ramdisk"
+ default y if USES_INITRAMFS
+ help
+ Embed the root filesystem into the kernel (initramfs).
+
+ choice
+ prompt "Compression"
+ default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ar71xx
+ default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ramips
+ default TARGET_INITRAMFS_COMPRESSION_NONE
+ depends on TARGET_ROOTFS_INITRAMFS
+ help
+ Select ramdisk compression.
+
+ config TARGET_INITRAMFS_COMPRESSION_NONE
+ bool "none"
+
+ config TARGET_INITRAMFS_COMPRESSION_GZIP
+ bool "gzip"
+
+ config TARGET_INITRAMFS_COMPRESSION_BZIP2
+ bool "bzip2"
+
+ config TARGET_INITRAMFS_COMPRESSION_LZMA
+ bool "lzma"
+
+ config TARGET_INITRAMFS_COMPRESSION_LZO
+ bool "lzo"
+
+ config TARGET_INITRAMFS_COMPRESSION_LZ4
+ bool "lz4"
+
+ config TARGET_INITRAMFS_COMPRESSION_XZ
+ bool "xz"
+ endchoice
+
+ config EXTERNAL_CPIO
+ string
+ prompt "Use external cpio" if TARGET_ROOTFS_INITRAMFS
+ default ""
+ help
+ Kernel uses specified external cpio as INITRAMFS_SOURCE.
+
+ comment "Root filesystem archives"
+
+ config TARGET_ROOTFS_CPIOGZ
+ bool "cpio.gz"
+ default y if USES_CPIOGZ
+ help
+ Build a compressed cpio archive of the root filesystem.
+
+ config TARGET_ROOTFS_TARGZ
+ bool "tar.gz"
+ default y if USES_TARGZ
+ help
+ Build a compressed tar archive of the root filesystem.
+
+ comment "Root filesystem images"
+
+ menuconfig TARGET_ROOTFS_EXT4FS
+ bool "ext4"
+ default y if USES_EXT4
+ help
+ Build an ext4 root filesystem.
+
+ config TARGET_EXT4_MAXINODE
+ int "Maximum number of inodes in root filesystem"
+ depends on TARGET_ROOTFS_EXT4FS
+ default 6000
+ help
+ Select the maximum number of inodes in the root filesystem.
+
+ config TARGET_EXT4_RESERVED_PCT
+ int "Percentage of reserved blocks in root filesystem"
+ depends on TARGET_ROOTFS_EXT4FS
+ default 0
+ help
+ Select the percentage of reserved blocks in the root filesystem.
+
+ choice
+ prompt "Root filesystem block size"
+ default TARGET_EXT4_BLOCKSIZE_4K
+ depends on TARGET_ROOTFS_EXT4FS
+ help
+ Select the block size of the root filesystem.
+
+ config TARGET_EXT4_BLOCKSIZE_4K
+ bool "4k"
+
+ config TARGET_EXT4_BLOCKSIZE_2K
+ bool "2k"
+
+ config TARGET_EXT4_BLOCKSIZE_1K
+ bool "1k"
+ endchoice
+
+ config TARGET_EXT4_BLOCKSIZE
+ int
+ default 4096 if TARGET_EXT4_BLOCKSIZE_4K
+ default 2048 if TARGET_EXT4_BLOCKSIZE_2K
+ default 1024 if TARGET_EXT4_BLOCKSIZE_1K
+ depends on TARGET_ROOTFS_EXT4FS
+
+ config TARGET_EXT4_JOURNAL
+ bool "Create a journaling filesystem"
+ depends on TARGET_ROOTFS_EXT4FS
+ default n
+ help
+ Create an ext4 filesystem with a journal.
+
+ config TARGET_ROOTFS_ISO
+ bool "iso"
+ default n
+ depends on TARGET_x86_generic
+ help
+ Create a bootable ISO image.
+
+ config TARGET_ROOTFS_JFFS2
+ bool "jffs2"
+ default y if USES_JFFS2
+ help
+ Build a JFFS2 root filesystem.
+
+ config TARGET_ROOTFS_JFFS2_NAND
+ bool "jffs2 for NAND"
+ default y if USES_JFFS2_NAND
+ depends on USES_JFFS2_NAND
+ help
+ Build a JFFS2 root filesystem for NAND flash.
+
+ menuconfig TARGET_ROOTFS_SQUASHFS
+ bool "squashfs"
+ default y if USES_SQUASHFS
+ help
+ Build a squashfs-lzma root filesystem.
+
+ config TARGET_SQUASHFS_BLOCK_SIZE
+ int "Block size (in KiB)"
+ depends on TARGET_ROOTFS_SQUASHFS
+ default 64 if LOW_MEMORY_FOOTPRINT
+ default 256
+
+ menuconfig TARGET_ROOTFS_UBIFS
+ bool "ubifs"
+ default y if USES_UBIFS
+ depends on USES_UBIFS
+ help
+ Build a UBIFS root filesystem.
+
+ choice
+ prompt "compression"
+ default TARGET_UBIFS_COMPRESSION_ZLIB
+ depends on TARGET_ROOTFS_UBIFS
+ help
+ Select compression type
+
+ config TARGET_UBIFS_COMPRESSION_NONE
+ bool "none"
+
+ config TARGET_UBIFS_COMPRESSION_LZO
+ bool "lzo"
+
+ config TARGET_UBIFS_COMPRESSION_ZLIB
+ bool "zlib"
+ endchoice
+
+ config TARGET_UBIFS_FREE_SPACE_FIXUP
+ bool "free space fixup" if TARGET_ROOTFS_UBIFS
+ default y
+ help
+ The filesystem free space has to be fixed up on first mount.
+
+ config TARGET_UBIFS_JOURNAL_SIZE
+ string
+ prompt "journal size" if TARGET_ROOTFS_UBIFS
+ default ""
+
+ config GRUB_IMAGES
+ bool "Build GRUB images (Linux x86 or x86_64 host only)"
+ depends on TARGET_x86_64 || (TARGET_x86 && !TARGET_x86_rdc)
+ depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
+ select PACKAGE_grub2
+ default y
+
+ config GRUB_CONSOLE
+ bool "Use Console Terminal (in addition to Serial)"
+ depends on GRUB_IMAGES
+ default n if (TARGET_x86_generic_Soekris45xx || TARGET_x86_generic_Soekris48xx || TARGET_x86_net5501 || TARGET_x86_geos || TARGET_x86_alix2)
+ default y
+
+ config GRUB_SERIAL
+ string "Serial port device"
+ depends on GRUB_IMAGES
+ default "hvc0" if TARGET_x86_xen_domu
+ default "ttyS0" if ! TARGET_x86_xen_domu
+
+ config GRUB_BAUDRATE
+ int "Serial port baud rate"
+ depends on GRUB_IMAGES
+ default 38400 if TARGET_x86_generic
+ default 38400 if TARGET_x86_geode
+ default 115200
+
+ config GRUB_BOOTOPTS
+ string "Extra kernel boot options"
+ depends on GRUB_IMAGES
+ default "xencons=hvc" if TARGET_x86_xen_domu
+ help
+ If you don't know, just leave it blank.
+
+ config GRUB_TIMEOUT
+ string "Seconds to wait before booting the default entry"
+ depends on GRUB_IMAGES
+ default "5"
+ help
+ If you don't know, 5 seconds is a reasonable default.
+
+ config VDI_IMAGES
+ bool "Build VirtualBox image files (VDI)"
+ depends on TARGET_x86 || TARGET_x86_64
+ select GRUB_IMAGES
+ select TARGET_IMAGES_PAD
+ select PACKAGE_kmod-e1000
+
+ config VMDK_IMAGES
+ bool "Build VMware image files (VMDK)"
+ depends on TARGET_x86 || TARGET_x86_64
+ select GRUB_IMAGES
+ select TARGET_IMAGES_PAD
+ select PACKAGE_kmod-e1000
+
+ config TARGET_IMAGES_PAD
+ bool "Pad images to filesystem size (for JFFS2)"
+ depends on GRUB_IMAGES
+
+ config TARGET_IMAGES_GZIP
+ bool "GZip images"
+ depends on TARGET_IMAGES_PAD || TARGET_ROOTFS_EXT4FS
+ default y
+
+ comment "Image Options"
+
+ source "target/linux/*/image/Config.in"
+
+ config TARGET_KERNEL_PARTSIZE
+ int "Kernel partition size (in MB)"
+ depends on GRUB_IMAGES
+ default 4
+
+ config TARGET_ROOTFS_PARTSIZE
+ int "Root filesystem partition size (in MB)"
+ depends on GRUB_IMAGES || TARGET_ROOTFS_EXT4FS || TARGET_rb532
+ default 48
+ help
+ Select the root filesystem partition size.
+
+ config TARGET_ROOTFS_PARTNAME
+ string "Root partition on target device"
+ depends on GRUB_IMAGES
+ help
+ Override the root partition on the final device. If left empty,
+ it will be mounted by PARTUUID which makes the kernel find the
+ appropriate disk automatically.
+
+
+ menuconfig TARGET_ROOTFS_INCLUDE_KERNEL
+ bool "Include kernel in root filesystem"
+ depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
+ default n
+ help
+ Include the kernel image in the rootfs. Typically, the image is placed
+ below /boot.
+
+ config TARGET_ROOTFS_INCLUDE_UIMAGE
+ bool "include uImage" if TARGET_ROOTFS_INCLUDE_KERNEL
+ default y
+ help
+ This option might not apply to all targets. Make sure
+ to check target/linux/<your_target>/image/Makefile to
+ see if this option will have any effect.
+
+ config TARGET_ROOTFS_INCLUDE_ZIMAGE
+ bool "include zImage" if TARGET_ROOTFS_INCLUDE_KERNEL
+ default y
+ help
+ This option might not apply to all targets. Make sure
+ to check target/linux/<your_target>/image/Makefile to
+ see if this option will have any effect.
+
+ config TARGET_ROOTFS_INCLUDE_FIT
+ bool "include FIT" if TARGET_ROOTFS_INCLUDE_KERNEL
+ default y
+ help
+ This option might not apply to all targets. Make sure
+ to check target/linux/<your_target>/image/Makefile to
+ see if this option will have any effect.
+
+ config TARGET_ROOTFS_INCLUDE_DTB
+ bool "Include DTB in root filesystem"
+ depends on USES_DEVICETREE && (TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS)
+ default n
+ help
+ Include the device tree blob file(s) in the rootfs. Typically the DTBs
+ are placed below /boot.
+
+endmenu
diff --git a/config/Config-kernel.in b/config/Config-kernel.in
new file mode 100644
index 0000000..4be5f53
--- /dev/null
+++ b/config/Config-kernel.in
@@ -0,0 +1,553 @@
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+config KERNEL_PRINTK
+ bool "Enable support for printk"
+ default y
+
+config KERNEL_CRASHLOG
+ bool "Crash logging"
+ depends on !(arm || powerpc || sparc || TARGET_uml)
+ default y
+
+config KERNEL_SWAP
+ bool "Support for paging of anonymous memory (swap)"
+ default y
+
+config KERNEL_DEBUG_FS
+ bool "Compile the kernel with debug filesystem enabled"
+ default y
+ help
+ debugfs is a virtual file system that kernel developers use to put
+ debugging files into. Enable this option to be able to read and
+ write to these files. Many common debugging facilities, such as
+ ftrace, require the existence of debugfs.
+
+config KERNEL_PERF_EVENTS
+ bool
+ default n
+
+config KERNEL_PROFILING
+ bool "Compile the kernel with profiling enabled"
+ default n
+ select KERNEL_PERF_EVENTS
+ help
+ Enable the extended profiling support mechanisms used by profilers such
+ as OProfile.
+
+config KERNEL_KALLSYMS
+ bool "Compile the kernel with symbol table information"
+ default y
+ help
+ This will give you more information in stack traces from kernel oopses.
+
+config KERNEL_FTRACE
+ bool "Compile the kernel with tracing support"
+ depends on !TARGET_uml
+ default n
+
+config KERNEL_FTRACE_SYSCALLS
+ bool "Trace system calls"
+ depends on KERNEL_FTRACE
+ default n
+
+config KERNEL_ENABLE_DEFAULT_TRACERS
+ bool "Trace process context switches and events"
+ depends on KERNEL_FTRACE
+ default n
+
+config KERNEL_FUNCTION_TRACER
+ bool "Function tracer"
+ depends on KERNEL_FTRACE
+ default n
+
+config KERNEL_FUNCTION_GRAPH_TRACER
+ bool "Function graph tracer"
+ depends on KERNEL_FUNCTION_TRACER
+ default n
+
+config KERNEL_DYNAMIC_FTRACE
+ bool "Enable/disable function tracing dynamically"
+ depends on KERNEL_FUNCTION_TRACER
+ default n
+
+config KERNEL_FUNCTION_PROFILER
+ bool "Function profiler"
+ depends on KERNEL_FUNCTION_TRACER
+ default n
+
+config KERNEL_DEBUG_KERNEL
+ bool
+ default n
+
+config KERNEL_DEBUG_INFO
+ bool "Compile the kernel with debug information"
+ default y
+ select KERNEL_DEBUG_KERNEL
+ help
+ This will compile your kernel and modules with debug information.
+
+config KERNEL_DEBUG_LL_UART_NONE
+ bool
+ default n
+ depends on arm
+
+config KERNEL_DEBUG_LL
+ bool
+ default n
+ depends on arm
+ select KERNEL_DEBUG_LL_UART_NONE
+ help
+ ARM low level debugging.
+
+config KERNEL_DYNAMIC_DEBUG
+ bool "Compile the kernel with dynamic printk"
+ select KERNEL_DEBUG_FS
+ default n
+ help
+ Compiles debug level messages into the kernel, which would not
+ otherwise be available at runtime. These messages can then be
+ enabled/disabled based on various levels of scope - per source file,
+ function, module, format string, and line number. This mechanism
+ implicitly compiles in all pr_debug() and dev_dbg() calls, which
+ enlarges the kernel text size by about 2%.
+
+config KERNEL_EARLY_PRINTK
+ bool "Compile the kernel with early printk"
+ default y if TARGET_bcm53xx
+ default n
+ depends on arm
+ select KERNEL_DEBUG_KERNEL
+ select KERNEL_DEBUG_LL if arm
+ help
+ Compile the kernel with early printk support. This is only useful for
+ debugging purposes to send messages over the serial console in early boot.
+ Enable this to debug early boot problems.
+
+config KERNEL_KPROBES
+ bool "Compile the kernel with kprobes support"
+ default n
+ select KERNEL_FTRACE
+ select KERNEL_PERF_EVENTS
+ help
+ Compiles the kernel with KPROBES support, which allows you to trap
+ at almost any kernel address and execute a callback function.
+ register_kprobe() establishes a probepoint and specifies the
+ callback. Kprobes is useful for kernel debugging, non-intrusive
+ instrumentation and testing.
+ If in doubt, say "N".
+
+config KERNEL_KPROBE_EVENT
+ bool
+ default y if KERNEL_KPROBES
+
+config KERNEL_AIO
+ bool "Compile the kernel with asynchronous IO support"
+ default n
+
+config KERNEL_DIRECT_IO
+ bool "Compile the kernel with direct IO support"
+ default n
+
+config KERNEL_FHANDLE
+ bool "Compile the kernel with support for fhandle syscalls"
+ default n
+
+config KERNEL_FANOTIFY
+ bool "Compile the kernel with modern file notification support"
+ default n
+
+config KERNEL_BLK_DEV_BSG
+ bool "Compile the kernel with SCSI generic v4 support for any block device"
+ default n
+
+config KERNEL_MAGIC_SYSRQ
+ bool "Compile the kernel with SysRq support"
+ default y
+
+config KERNEL_COREDUMP
+ bool
+
+config KERNEL_ELF_CORE
+ bool "Enable process core dump support"
+ select KERNEL_COREDUMP
+ default y
+
+config KERNEL_PROVE_LOCKING
+ bool "Enable kernel lock checking"
+ select KERNEL_DEBUG_KERNEL
+ default n
+
+config KERNEL_PRINTK_TIME
+ bool "Enable printk timestamps"
+ default y
+
+config KERNEL_SLUB_DEBUG
+ bool
+
+config KERNEL_SLUB_DEBUG_ON
+ bool
+
+config KERNEL_SLABINFO
+ select KERNEL_SLUB_DEBUG
+ select KERNEL_SLUB_DEBUG_ON
+ bool "Enable /proc slab debug info"
+
+config KERNEL_PROC_PAGE_MONITOR
+ bool "Enable /proc page monitoring"
+
+config KERNEL_RELAY
+ bool
+
+config KERNEL_KEXEC
+ bool "Enable kexec support"
+
+config USE_RFKILL
+ bool "Enable rfkill support"
+ default RFKILL_SUPPORT
+
+config USE_SPARSE
+ bool "Enable sparse check during kernel build"
+ default n
+
+config KERNEL_DEVTMPFS
+ bool "Compile the kernel with device tmpfs enabled"
+ default n
+ help
+ devtmpfs is a simple, kernel-managed /dev filesystem. The kernel creates
+ devices nodes for all registered devices ti simplify boot, but leaves more
+ complex tasks to userspace (e.g. udev).
+
+if KERNEL_DEVTMPFS
+
+ config KERNEL_DEVTMPFS_MOUNT
+ bool "Automatically mount devtmpfs after root filesystem is mounted"
+ default n
+
+endif
+
+#
+# CGROUP support symbols
+#
+
+config KERNEL_CGROUPS
+ bool "Enable kernel cgroups"
+ default n
+
+if KERNEL_CGROUPS
+
+ config KERNEL_CGROUP_DEBUG
+ bool "Example debug cgroup subsystem"
+ default n
+ help
+ This option enables a simple cgroup subsystem that
+ exports useful debugging information about the cgroups
+ framework.
+
+ config KERNEL_FREEZER
+ bool
+ default y if KERNEL_CGROUP_FREEZER
+
+ config KERNEL_CGROUP_FREEZER
+ bool "Freezer cgroup subsystem"
+ default y
+ help
+ Provides a way to freeze and unfreeze all tasks in a
+ cgroup.
+
+ config KERNEL_CGROUP_DEVICE
+ bool "Device controller for cgroups"
+ default y
+ help
+ Provides a cgroup implementing whitelists for devices which
+ a process in the cgroup can mknod or open.
+
+ config KERNEL_CGROUP_PIDS
+ bool "PIDs cgroup subsystem"
+ default y
+ help
+ Provides enforcement of process number limits in the scope of a
+ cgroup.
+
+ config KERNEL_CPUSETS
+ bool "Cpuset support"
+ default n
+ help
+ This option will let you create and manage CPUSETs which
+ allow dynamically partitioning a system into sets of CPUs and
+ Memory Nodes and assigning tasks to run only within those sets.
+ This is primarily useful on large SMP or NUMA systems.
+
+ config KERNEL_PROC_PID_CPUSET
+ bool "Include legacy /proc/<pid>/cpuset file"
+ default n
+ depends on KERNEL_CPUSETS
+
+ config KERNEL_CGROUP_CPUACCT
+ bool "Simple CPU accounting cgroup subsystem"
+ default n
+ help
+ Provides a simple Resource Controller for monitoring the
+ total CPU consumed by the tasks in a cgroup.
+
+ config KERNEL_RESOURCE_COUNTERS
+ bool "Resource counters"
+ default n
+ help
+ This option enables controller independent resource accounting
+ infrastructure that works with cgroups.
+
+ config KERNEL_MM_OWNER
+ bool
+ default y if KERNEL_MEMCG
+
+ config KERNEL_MEMCG
+ bool "Memory Resource Controller for Control Groups"
+ default n
+ depends on KERNEL_RESOURCE_COUNTERS || !LINUX_3_18
+ help
+ Provides a memory resource controller that manages both anonymous
+ memory and page cache. (See Documentation/cgroups/memory.txt)
+
+ Note that setting this option increases fixed memory overhead
+ associated with each page of memory in the system. By this,
+ 20(40)bytes/PAGE_SIZE on 32(64)bit system will be occupied by memory
+ usage tracking struct at boot. Total amount of this is printed out
+ at boot.
+
+ Only enable when you're ok with these tradeoffs and really
+ sure you need the memory resource controller. Even when you enable
+ this, you can set "cgroup_disable=memory" at your boot option to
+ disable memory resource controller and you can avoid overheads
+ (but lose benefits of memory resource controller).
+
+ This config option also selects MM_OWNER config option, which
+ could in turn add some fork/exit overhead.
+
+ config KERNEL_MEMCG_SWAP
+ bool "Memory Resource Controller Swap Extension"
+ default n
+ depends on KERNEL_MEMCG
+ help
+ Add swap management feature to memory resource controller. When you
+ enable this, you can limit mem+swap usage per cgroup. In other words,
+ when you disable this, memory resource controller has no cares to
+ usage of swap...a process can exhaust all of the swap. This extension
+ is useful when you want to avoid exhaustion swap but this itself
+ adds more overheads and consumes memory for remembering information.
+ Especially if you use 32bit system or small memory system, please
+ be careful about enabling this. When memory resource controller
+ is disabled by boot option, this will be automatically disabled and
+ there will be no overhead from this. Even when you set this config=y,
+ if boot option "swapaccount=0" is set, swap will not be accounted.
+ Now, memory usage of swap_cgroup is 2 bytes per entry. If swap page
+ size is 4096bytes, 512k per 1Gbytes of swap.
+
+ config KERNEL_MEMCG_SWAP_ENABLED
+ bool "Memory Resource Controller Swap Extension enabled by default"
+ default n
+ depends on KERNEL_MEMCG_SWAP
+ help
+ Memory Resource Controller Swap Extension comes with its price in
+ a bigger memory consumption. General purpose distribution kernels
+ which want to enable the feature but keep it disabled by default
+ and let the user enable it by swapaccount boot command line
+ parameter should have this option unselected.
+
+ Those who want to have the feature enabled by default should
+ select this option (if, for some reason, they need to disable it,
+ then swapaccount=0 does the trick).
+
+
+ config KERNEL_MEMCG_KMEM
+ bool "Memory Resource Controller Kernel Memory accounting (EXPERIMENTAL)"
+ default n
+ depends on KERNEL_MEMCG
+ help
+ The Kernel Memory extension for Memory Resource Controller can limit
+ the amount of memory used by kernel objects in the system. Those are
+ fundamentally different from the entities handled by the standard
+ Memory Controller, which are page-based, and can be swapped. Users of
+ the kmem extension can use it to guarantee that no group of processes
+ will ever exhaust kernel resources alone.
+
+ config KERNEL_CGROUP_PERF
+ bool "Enable perf_event per-cpu per-container group (cgroup) monitoring"
+ select KERNEL_PERF_EVENTS
+ default n
+ help
+ This option extends the per-cpu mode to restrict monitoring to
+ threads which belong to the cgroup specified and run on the
+ designated cpu.
+
+ menuconfig KERNEL_CGROUP_SCHED
+ bool "Group CPU scheduler"
+ default n
+ help
+ This feature lets CPU scheduler recognize task groups and control CPU
+ bandwidth allocation to such task groups. It uses cgroups to group
+ tasks.
+
+ if KERNEL_CGROUP_SCHED
+
+ config KERNEL_FAIR_GROUP_SCHED
+ bool "Group scheduling for SCHED_OTHER"
+ default n
+
+ config KERNEL_CFS_BANDWIDTH
+ bool "CPU bandwidth provisioning for FAIR_GROUP_SCHED"
+ default n
+ depends on KERNEL_FAIR_GROUP_SCHED
+ help
+ This option allows users to define CPU bandwidth rates (limits) for
+ tasks running within the fair group scheduler. Groups with no limit
+ set are considered to be unconstrained and will run with no
+ restriction.
+ See tip/Documentation/scheduler/sched-bwc.txt for more information.
+
+ config KERNEL_RT_GROUP_SCHED
+ bool "Group scheduling for SCHED_RR/FIFO"
+ default n
+ help
+ This feature lets you explicitly allocate real CPU bandwidth
+ to task groups. If enabled, it will also make it impossible to
+ schedule realtime tasks for non-root users until you allocate
+ realtime bandwidth for them.
+
+ endif
+
+ config KERNEL_BLK_CGROUP
+ bool "Block IO controller"
+ default y
+ help
+ Generic block IO controller cgroup interface. This is the common
+ cgroup interface which should be used by various IO controlling
+ policies.
+
+ Currently, CFQ IO scheduler uses it to recognize task groups and
+ control disk bandwidth allocation (proportional time slice allocation)
+ to such task groups. It is also used by bio throttling logic in
+ block layer to implement upper limit in IO rates on a device.
+
+ This option only enables generic Block IO controller infrastructure.
+ One needs to also enable actual IO controlling logic/policy. For
+ enabling proportional weight division of disk bandwidth in CFQ, set
+ CONFIG_CFQ_GROUP_IOSCHED=y; for enabling throttling policy, set
+ CONFIG_BLK_DEV_THROTTLING=y.
+
+ config KERNEL_DEBUG_BLK_CGROUP
+ bool "Enable Block IO controller debugging"
+ default n
+ depends on KERNEL_BLK_CGROUP
+ help
+ Enable some debugging help. Currently it exports additional stat
+ files in a cgroup which can be useful for debugging.
+
+ config KERNEL_NET_CLS_CGROUP
+ bool "Control Group Classifier"
+ default y
+
+ config KERNEL_NETPRIO_CGROUP
+ bool "Network priority cgroup"
+ default y
+
+endif
+
+#
+# Namespace support symbols
+#
+
+config KERNEL_NAMESPACES
+ bool "Enable kernel namespaces"
+ default n
+
+if KERNEL_NAMESPACES
+
+ config KERNEL_UTS_NS
+ bool "UTS namespace"
+ default y
+ help
+ In this namespace, tasks see different info provided
+ with the uname() system call.
+
+ config KERNEL_IPC_NS
+ bool "IPC namespace"
+ default y
+ help
+ In this namespace, tasks work with IPC ids which correspond to
+ different IPC objects in different namespaces.
+
+ config KERNEL_USER_NS
+ bool "User namespace (EXPERIMENTAL)"
+ default y
+ help
+ This allows containers, i.e. vservers, to use user namespaces
+ to provide different user info for different servers.
+
+ config KERNEL_PID_NS
+ bool "PID Namespaces"
+ default y
+ help
+ Support process id namespaces. This allows having multiple
+ processes with the same pid as long as they are in different
+ pid namespaces. This is a building block of containers.
+
+ config KERNEL_NET_NS
+ bool "Network namespace"
+ default y
+ help
+ Allow user space to create what appear to be multiple instances
+ of the network stack.
+
+endif
+
+#
+# LXC related symbols
+#
+
+config KERNEL_LXC_MISC
+ bool "Enable miscellaneous LXC related options"
+ default n
+
+if KERNEL_LXC_MISC
+
+ config KERNEL_DEVPTS_MULTIPLE_INSTANCES
+ bool "Support multiple instances of devpts"
+ default y
+ help
+ Enable support for multiple instances of devpts filesystem.
+ If you want to have isolated PTY namespaces (eg: in containers),
+ say Y here. Otherwise, say N. If enabled, each mount of devpts
+ filesystem with the '-o newinstance' option will create an
+ independent PTY namespace.
+
+ config KERNEL_POSIX_MQUEUE
+ bool "POSIX Message Queues"
+ default y
+ help
+ POSIX variant of message queues is a part of IPC. In POSIX message
+ queues every message has a priority which decides about succession
+ of receiving it by a process. If you want to compile and run
+ programs written e.g. for Solaris with use of its POSIX message
+ queues (functions mq_*) say Y here.
+
+ POSIX message queues are visible as a filesystem called 'mqueue'
+ and can be mounted somewhere if you want to do filesystem
+ operations on message queues.
+
+endif
+
+config KERNEL_SECCOMP_FILTER
+ bool
+ default n
+
+config KERNEL_SECCOMP
+ bool "Enable seccomp support"
+ depends on !(TARGET_uml)
+ select KERNEL_SECCOMP_FILTER
+ default n
+ help
+ Build kernel with support for seccomp.