aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.0/302-mips_no_branch_likely.patch
diff options
context:
space:
mode:
authorJames <>2015-11-04 11:49:21 +0000
committerJames <>2015-11-04 11:49:21 +0000
commit716ca530e1c4515d8683c9d5be3d56b301758b66 (patch)
tree700eb5bcc1a462a5f21dcec15ce7c97ecfefa772 /target/linux/generic/patches-4.0/302-mips_no_branch_likely.patch
downloadtrunk-47381-master.tar.gz
trunk-47381-master.tar.bz2
trunk-47381-master.zip
trunk-47381HEADmaster
Diffstat (limited to 'target/linux/generic/patches-4.0/302-mips_no_branch_likely.patch')
-rw-r--r--target/linux/generic/patches-4.0/302-mips_no_branch_likely.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.0/302-mips_no_branch_likely.patch b/target/linux/generic/patches-4.0/302-mips_no_branch_likely.patch
new file mode 100644
index 0000000..44c6b04
--- /dev/null
+++ b/target/linux/generic/patches-4.0/302-mips_no_branch_likely.patch
@@ -0,0 +1,11 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -87,7 +87,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
+ # machines may also. Since BFD is incredibly buggy with respect to
+ # crossformat linking we rely on the elf2ecoff tool for format conversion.
+ #
+-cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
++cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
+ cflags-y += -msoft-float
+ LDFLAGS_vmlinux += -G 0 -static -n -nostdlib --gc-sections
+ KBUILD_AFLAGS_MODULE += -mlong-calls