aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
diff options
context:
space:
mode:
authorJames <>2015-11-04 11:49:21 +0000
committerJames <>2015-11-04 11:49:21 +0000
commit716ca530e1c4515d8683c9d5be3d56b301758b66 (patch)
tree700eb5bcc1a462a5f21dcec15ce7c97ecfefa772 /target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
downloadtrunk-47381-master.tar.gz
trunk-47381-master.tar.bz2
trunk-47381-master.zip
trunk-47381HEADmaster
Diffstat (limited to 'target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk')
-rw-r--r--target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
new file mode 100644
index 0000000..dcf6e05
--- /dev/null
+++ b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Raspberry Pi
+endef
+define Profile/Default/Description
+ Raspberry Pi
+endef
+$(eval $(call Profile,Default))
+
+define Profile/RaspberryPi_B
+ NAME:=Raspberry Pi Model B
+endef
+define Profile/RaspberryPi_B/Description
+ Raspberry Pi Model B
+endef
+$(eval $(call Profile,RaspberryPi_B))
+
+define Profile/RaspberryPi_BPlus
+ NAME:=Raspberry Pi Model B+
+endef
+define Profile/RaspberryPi_BPlus/Description
+ Raspberry Pi Model B+
+endef
+$(eval $(call Profile,RaspberryPi_BPlus))
+
+define Profile/RaspberryPi_CM
+ NAME:=Raspberry Pi Compute Module
+endef
+define Profile/RaspberryPi_CM/Description
+ Raspberry Pi Model Compute Module
+endef
+$(eval $(call Profile,RaspberryPi_CM))