aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/wwan/Makefile
diff options
context:
space:
mode:
authorJames <>2015-11-04 11:49:21 +0000
committerJames <>2015-11-04 11:49:21 +0000
commit716ca530e1c4515d8683c9d5be3d56b301758b66 (patch)
tree700eb5bcc1a462a5f21dcec15ce7c97ecfefa772 /package/network/utils/wwan/Makefile
downloadtrunk-47381-master.tar.gz
trunk-47381-master.tar.bz2
trunk-47381-master.zip
trunk-47381HEADmaster
Diffstat (limited to 'package/network/utils/wwan/Makefile')
-rw-r--r--package/network/utils/wwan/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/package/network/utils/wwan/Makefile b/package/network/utils/wwan/Makefile
new file mode 100644
index 0000000..8d388dc
--- /dev/null
+++ b/package/network/utils/wwan/Makefile
@@ -0,0 +1,35 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wwan
+PKG_VERSION:=2014-07-17
+PKG_RELEASE=1
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=
+
+PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/wwan
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Generic OpenWrt 3G/4G proto handler
+endef
+
+define Build/Compile
+ true
+endef
+
+define Package/wwan/install
+ $(INSTALL_DIR) $(1)/lib/netifd/proto/
+ $(CP) ./files/wwan.sh $(1)/lib/netifd/proto/
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/usb
+ $(INSTALL_BIN) ./files/wwan.usb $(1)/etc/hotplug.d/usb/00_wwan.sh
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/usbmisc
+ $(INSTALL_BIN) ./files/wwan.usbmisc $(1)/etc/hotplug.d/usbmisc/00_wwan.sh
+ $(INSTALL_DIR) $(1)/lib/network/wwan/
+ $(INSTALL_DATA) ./files/data/* $(1)/lib/network/wwan/
+endef
+
+$(eval $(call BuildPackage,wwan))