summaryrefslogtreecommitdiffstats
path: root/master/16m-rom
diff options
context:
space:
mode:
Diffstat (limited to 'master/16m-rom')
-rw-r--r--master/16m-rom25
1 files changed, 25 insertions, 0 deletions
diff --git a/master/16m-rom b/master/16m-rom
new file mode 100644
index 0000000..92c5115
--- /dev/null
+++ b/master/16m-rom
@@ -0,0 +1,25 @@
+diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
+index 7bf2f27..8132a39 100644
+--- a/target/linux/ar71xx/image/Makefile
++++ b/target/linux/ar71xx/image/Makefile
+@@ -268,9 +268,9 @@ $(Device/tplink)
+ KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux-initramfs.bin.lzma | loader-kernel | mktplinkfw-initramfs
+ endef
+
+-define Device/tplink-4m
++define Device/tplink-16m
+ $(Device/tplink-nolzma)
+- TPLINK_FLASHLAYOUT := 4M
++ TPLINK_FLASHLAYOUT := 16M
+ IMAGE_SIZE := 3904k
+ endef
+
+@@ -547,7 +547,7 @@ define Device/tl-mr3220-v2
+ endef
+
+ define Device/tl-mr3420-v1
+- $(Device/tplink-4m)
++ $(Device/tplink-16m)
+ BOARDNAME := TL-MR3420
+ DEVICE_PROFILE := TLMR3420
+ TPLINK_HWID := 0x34200001