aboutsummaryrefslogtreecommitdiffstats
path: root/tools/ppl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/ppl/Makefile')
-rw-r--r--tools/ppl/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/tools/ppl/Makefile b/tools/ppl/Makefile
new file mode 100644
index 0000000..082b200
--- /dev/null
+++ b/tools/ppl/Makefile
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ppl
+PKG_VERSION:=1.1
+
+PKG_SOURCE_URL:=http://bugseng.com/products/ppl/download/ftp/releases/$(PKG_VERSION)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=82617a9c4e08606111ed9d2dc37ececa
+
+HOST_FIXUP:=autoreconf
+
+HOST_BUILD_PARALLEL:=1
+HOST_CONFIGURE_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR)/$(3); \
+ $(HOST_CONFIGURE_CMD) \
+ $(HOST_CONFIGURE_VARS) \
+ $(HOST_CONFIGURE_ARGS); \
+ )
+endef
+
+$(eval $(call HostBuild))