aboutsummaryrefslogtreecommitdiffstats
path: root/tools/patch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/patch/Makefile')
-rw-r--r--tools/patch/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/patch/Makefile b/tools/patch/Makefile
new file mode 100644
index 0000000..1ea96bf
--- /dev/null
+++ b/tools/patch/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=patch
+PKG_VERSION:=2.7.5
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/patch
+PKG_MD5SUM:=e3da7940431633fb65a01b91d3b7a27a
+
+HOST_BUILD_PARALLEL := 1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOSTCC := $(HOSTCC_NOCACHE)
+HOSTCXX := $(HOSTCXX_NOCACHE)
+
+$(eval $(call HostBuild))