aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mtools
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mtools')
-rw-r--r--tools/mtools/Makefile38
-rw-r--r--tools/mtools/patches/100-compile_fix.patch19
2 files changed, 57 insertions, 0 deletions
diff --git a/tools/mtools/Makefile b/tools/mtools/Makefile
new file mode 100644
index 0000000..13de447
--- /dev/null
+++ b/tools/mtools/Makefile
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2012-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mtools
+PKG_VERSION:=4.0.18
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=17b9f525c1ae3583a478338deb7fbc19
+PKG_CAT:=zcat
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_VARS += \
+ ac_cv_header_iconv_h=no
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) mcopy mmd
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/mcopy $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/mmd $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mcopy
+ rm -f $(STAGING_DIR_HOST)/bin/mmd
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/mtools/patches/100-compile_fix.patch b/tools/mtools/patches/100-compile_fix.patch
new file mode 100644
index 0000000..698e156
--- /dev/null
+++ b/tools/mtools/patches/100-compile_fix.patch
@@ -0,0 +1,19 @@
+--- a/sysincludes.h
++++ b/sysincludes.h
+@@ -101,14 +101,8 @@ typedef void *caddr_t;
+ #if defined __GNUC__ && defined __STDC__
+ /* gcc -traditional doesn't have PACKED, UNUSED and NORETURN */
+ # define PACKED __attribute__ ((packed))
+-# if __GNUC__ == 2 && __GNUC_MINOR__ > 6 || __GNUC__ >= 3
+-/* gcc 2.6.3 doesn't have "unused" */ /* mool */
+-# define UNUSED(x) x __attribute__ ((unused));x
+-# define UNUSEDP __attribute__ ((unused))
+-# else
+-# define UNUSED(x) x
+-# define UNUSEDP /* */
+-# endif
++# define UNUSED(x) x
++# define UNUSEDP /* */
+ # define NORETURN __attribute__ ((noreturn))
+ #else
+ # define UNUSED(x) x