aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mpfr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mpfr/Makefile')
-rw-r--r--tools/mpfr/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/tools/mpfr/Makefile b/tools/mpfr/Makefile
new file mode 100644
index 0000000..16624a7
--- /dev/null
+++ b/tools/mpfr/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2009-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpfr
+PKG_VERSION:=3.1.3
+
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION) \
+ @GNU/mpfr
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=5fdfa3cfa5c86514ee4a241a1affa138
+
+HOST_BUILD_PARALLEL:=1
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-gmp=$(STAGING_DIR_HOST)
+
+$(eval $(call HostBuild))