aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mm-macros/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mm-macros/Makefile')
-rw-r--r--tools/mm-macros/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/tools/mm-macros/Makefile b/tools/mm-macros/Makefile
new file mode 100644
index 0000000..94ce0de
--- /dev/null
+++ b/tools/mm-macros/Makefile
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mm-macros
+PKG_VERSION:=0.9.7
+
+PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/mm-common/0.9
+PKG_SOURCE:=mm-common-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=a8b7c11db81a72168bf38d88d97df686
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/mm-common-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+ $(INSTALL_DATA) $(HOST_BUILD_DIR)/macros/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))