aboutsummaryrefslogtreecommitdiffstats
path: root/tools/m4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/m4/Makefile')
-rw-r--r--tools/m4/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/m4/Makefile b/tools/m4/Makefile
new file mode 100644
index 0000000..47c3321
--- /dev/null
+++ b/tools/m4/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=m4
+PKG_VERSION:=1.4.17
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=12a3c829301a4fd6586a57d3fcf196dc
+PKG_CAT:=xzcat
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_VARS += gl_cv_func_strstr_linear=no
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))