aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gmp/Makefile')
-rw-r--r--tools/gmp/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/tools/gmp/Makefile b/tools/gmp/Makefile
new file mode 100644
index 0000000..fac05e3
--- /dev/null
+++ b/tools/gmp/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gmp
+PKG_VERSION:=5.1.3
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/gmp/
+PKG_MD5SUM:=e5fe367801ff067b923d1e6a126448aa
+
+HOST_FIXUP:=autoreconf
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --disable-assembly \
+ --enable-cxx \
+ --enable-mpbsd
+
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
+$(eval $(call HostBuild))