aboutsummaryrefslogtreecommitdiffstats
path: root/tools/flex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/flex/Makefile')
-rw-r--r--tools/flex/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
new file mode 100644
index 0000000..0e56ede
--- /dev/null
+++ b/tools/flex/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=flex
+PKG_VERSION:=2.5.39
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=77d44c6bb8c0705e0017ab9a84a1502b
+PKG_CAT:=bzcat
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += --disable-shared
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))